Modify

Opened 2 weeks ago

Closed 13 days ago

Last modified 13 days ago

#15122 closed defect (fixed)

trying to import .osm from ArcGIS

Reported by: beta.84@… Owned by: team
Priority: normal Milestone: 17.08
Component: Core Version: latest
Keywords: template_report arcgis Cc:

Description

What steps will reproduce the problem?

  1. import .osm in ArcGis
  2. export to .osm
  3. open with josm

What is the expected result?

open the .osm data

What happens instead?

error

Please provide any additional information below. Attach a screenshot if possible.

The problem occurs even if i make no edits in ArcGIS

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-30 17:07:42 +0200 (Sun, 30 Jul 2017)
Build-Date:2017-07-30 15:14:00
Revision:12542
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12542 de) Windows 10 64-Bit
OS Build number: Windows 10 Education 1607 (14393)
Memory Usage: 133 MB / 989 MB (58 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080, \Display1 1280x1024
Maximum Screen Size: 1920x1080
Program arguments: [%UserProfile%\Documents\ArcGIS\Gis_export_osm\GK_navi_Amelinghausen.osm]

Plugins:
+ turnrestrictions (33088)

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.UncheckedParseException: The date string (2017-06-01 11:32:17Z) could not be parsed.. Ursache: java.lang.IllegalArgumentException: 2017-06-01 11:32:17Z


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (31) of main
org.openstreetmap.josm.tools.UncheckedParseException: The date string (2017-06-01 11:32:17Z) could not be parsed.
	at org.openstreetmap.josm.tools.date.DateUtils.tsFromString(DateUtils.java:141)
	at org.openstreetmap.josm.io.OsmReader.readCommon(OsmReader.java:479)
	at org.openstreetmap.josm.io.OsmReader.parseNode(OsmReader.java:229)
	at org.openstreetmap.josm.io.OsmReader.parseOsm(OsmReader.java:168)
	at org.openstreetmap.josm.io.OsmReader.parseRoot(OsmReader.java:125)
	at org.openstreetmap.josm.io.OsmReader.parse(OsmReader.java:111)
	at org.openstreetmap.josm.io.OsmReader.doParseDataSet(OsmReader.java:615)
	at org.openstreetmap.josm.io.OsmReader.parseDataSet(OsmReader.java:666)
	at org.openstreetmap.josm.io.OsmImporter.parseDataSet(OsmImporter.java:127)
	at org.openstreetmap.josm.io.OsmImporter.loadLayer(OsmImporter.java:117)
	at org.openstreetmap.josm.io.OsmImporter.importData(OsmImporter.java:94)
	at org.openstreetmap.josm.io.OsmImporter.importData(OsmImporter.java:79)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:92)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:355)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:308)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: 2017-06-01 11:32:17Z
	at com.sun.org.apache.xerces.internal.jaxp.datatype.XMLGregorianCalendarImpl$Parser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.datatype.XMLGregorianCalendarImpl.<init>(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.datatype.DatatypeFactoryImpl.newXMLGregorianCalendar(Unknown Source)
	at org.openstreetmap.josm.tools.date.DateUtils.tsFromString(DateUtils.java:139)
	... 21 more

Attachments (3)

GK_navi_Amelinghausen.osm (1.9 MB) - added by beat.84@… 2 weeks ago.
export data from ArcGIS, Screenshot
Screenshot.png (89.1 KB) - added by anonymous 2 weeks ago.
josm_1.png (197.9 KB) - added by beta.84@… 13 days ago.
screenshot just befor the error

Change History (9)

Changed 2 weeks ago by beat.84@…

Attachment: GK_navi_Amelinghausen.osm added

export data from ArcGIS, Screenshot

Changed 2 weeks ago by anonymous

Attachment: Screenshot.png added

comment:1 Changed 2 weeks ago by Don-vip

Actually it's rather a bug on ArcGis side, it should stick to the "official" date format of the OSM API we also use in JOSM. Have you filed a bug report to ESRI?

comment:2 Changed 2 weeks ago by Don-vip

Keywords: arcgis added

Changed 13 days ago by beta.84@…

Attachment: josm_1.png added

screenshot just befor the error

comment:3 Changed 13 days ago by beta.84@…

I'm not sure but i don't think it's a problem with the export. I've tryed to open it with QGIS too and everything was fine. Also the reimport with ArcGis is no problem. I've made another screenshot just befor the error occurs.

comment:4 Changed 13 days ago by bastiK

In 12588/josm:

see #15122 - handle UncheckedParseException gracefully

comment:5 Changed 13 days ago by bastiK

Resolution: fixed
Status: newclosed

In 12589/josm:

fix #15122 - add date format for ArcGIS-exported osm data

comment:6 in reply to:  1 Changed 13 days ago by bastiK

Milestone: 17.08

Replying to Don-vip:

Actually it's rather a bug on ArcGis side, it should stick to the "official" date format of the OSM API we also use in JOSM. Have you filed a bug report to ESRI?

We recognize quite a few formats, so one more won't hurt.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.