Modify

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 11 days ago

#15108 closed defect (fixed)

Spurious 'key inside key' warning for multipolygons

Reported by: maxerickson@… Owned by: maxerickson@…
Priority: normal Milestone: 17.08
Component: Core validator Version:
Keywords: template_report mapcss regression Cc: bastiK

Description

What steps will reproduce the problem?

  1. Create a multipolygon tagged leisure=track.
  2. Run validation

What is the expected result?

There should be no warning.

What happens instead?

There is warning for leisure inside leisure, reporting the relation and a node from an outer way.

Please provide any additional information below. Attach a screenshot if possible.

Presumably impacts keys other than leisure.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-30 17:07:42 +0200 (Sun, 30 Jul 2017)
Build-Date:2017-07-30 15:14:00
Revision:12542
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12542 en) Linux Arch Linux
Memory Usage: 704 MB / 711 MB (242 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) Server VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800
VM arguments: [-Djosm.restart=true]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.5)
+ OpeningHoursEditor (33185)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ measurement (33088)
+ opendata (33438)
+ reverter (33088)
+ tagging-preset-tester (33004)
+ todo (30200)
+ turnrestrictions (33088)
+ undelete (33480)
+ utilsplugin2 (33328)
+ wikipedia (33288)

Tagging presets:
+ ${HOME}/josm/my.presets.xml
+ ${HOME}/name-suggestion-index/name-suggestions.presets.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
+ ${HOME}/josm/Style.BuildingYes.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1

Validator rules:
+ ${HOME}/josm/my.validator.mapcss

Last errors/warnings:
- W: Unable to convert property z-index to type class java.lang.Float: found -1
- W: Unable to convert property z-index to type class java.lang.Float: found -1
- W: Unable to convert property z-index to type class java.lang.Float: found -1
- W: Unable to convert property z-index to type class java.lang.Float: found -1
- W: Unable to convert property z-index to type class java.lang.Float: found -1
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method

Attachments (2)

insidetest.osm (1.1 KB) - added by maxerickson@… 3 weeks ago.
sample data
Screenshot_2017-08-02_13-07-55.png (106.6 KB) - added by maxerickson@… 3 weeks ago.
screenshot

Download all attachments as: .zip

Change History (17)

comment:1 Changed 3 weeks ago by Don-vip

Owner: changed from team to maxerickson@…
Status: newneedinfo

By following the bug description I got no error, can you please attach a sample .osm file? Thanks.

Changed 3 weeks ago by maxerickson@…

Attachment: insidetest.osm added

sample data

Changed 3 weeks ago by maxerickson@…

screenshot

comment:2 Changed 3 weeks ago by Klumbumbus

I too get no error even with your sample file. Please check if you still get the error when you disable your custom mappaint style ${HOME}/josm/Style.BuildingYes.mapcss and your custom rule ${HOME}/josm/my.validator.mapcss.

comment:3 Changed 3 weeks ago by maxerickson@…

Deactivated (but did not remove) the local customizations. Also removed custom presets. Restarted and still got the spurious warning.

comment:4 Changed 3 weeks ago by Klumbumbus

What happens if you download and validate another track multipolygon, e.g. at https://www.openstreetmap.org/#map=19/50.70419/12.84406?

comment:5 Changed 3 weeks ago by maxerickson@…

Same warning. My initial report was after I had seen it several times, also on other leisure multipolygons (a golf course).

I doubt it matters, but additional information not included above: My JRE is installed via AUR.

comment:6 Changed 3 weeks ago by Klumbumbus

Do you get a similar warning for https://www.openstreetmap.org/relation/7005977?

comment:7 Changed 3 weeks ago by Don-vip

Cc: bastiK added
Keywords: mapcss added

I don't see how the mapCSS rule:

node[tag("leisure") = parent_tag("leisure")]  *[leisure] {
  throwWarning: tr("{0} inside {1}", concat("leisure=", tag("leisure")), concat("leisure=", tag("leisure")));
  group: tr("{0} inside {1}", "leisure", "leisure");
}

can issue a warning if the node does not have any leisure tag. You're sure about that I imagine?

comment:8 in reply to:  5 Changed 3 weeks ago by Don-vip

Replying to maxerickson@…:

My JRE is installed via AUR.

Can you please try with another JRE?

comment:9 Changed 3 weeks ago by maxerickson@…

Switched to the Arch OpenJDK package. https://www.openstreetmap.org/relation/7005977 warns for building and for tourism.

Before switching I had ran with the Oracle JRE and --skip-plugins and also still had the error.

comment:10 Changed 3 weeks ago by maxerickson@…

Using https://josm.openstreetmap.de/download/, the spurious warning does not occur until 12542, it isn't present in 12539.

(using command lines like "java -jar josm-snapshot-12539.jar --skip-plugins", having switched various things back on and back to the HotSpot VM)

comment:11 Changed 3 weeks ago by maxerickson@…

And the error no longer occurs in 12556. ¯\_(ツ)_/¯

comment:12 Changed 3 weeks ago by Don-vip

Keywords: regression added
Milestone: 17.08
Resolution: fixed
Status: needinfoclosed

OK understood, I messed up in r12541 and fixed the error a few hours too late in r12544. Unfortunately you got a buggy build in between. Thanks for the report !

comment:13 Changed 3 weeks ago by Klumbumbus

Ticket #15105 has been marked as a duplicate of this ticket.

comment:14 Changed 13 days ago by Klumbumbus

Ticket #15132 has been marked as a duplicate of this ticket.

comment:15 Changed 11 days ago by Klumbumbus

Ticket #15144 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain maxerickson@….
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.