Modify

Opened 2 months ago

Closed 8 weeks ago

#15062 closed defect (fixed)

NPE while loading JOSM (related with IPv6 it seems)

Reported by: naoliv Owned by: team
Priority: normal Milestone: 17.07
Component: Core Version:
Keywords: Cc:

Description

I saw this while loading JOSM:

2017-07-24 09:34:51.103 GRAVE: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Causa: java.lang.NullPointerException
java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitAndReturn(GuiHelper.java:172)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:836)
	at org.openstreetmap.josm.actions.RestartAction.restartJOSM(RestartAction.java:87)
	at org.openstreetmap.josm.gui.MainApplication.lambda$checkIPv6$5(MainApplication.java:501)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.Main.addMapFrameListener(Main.java:1172)
	at org.openstreetmap.josm.actions.SessionSaveAsAction.<init>(SessionSaveAsAction.java:75)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveSessionAction.<init>(SaveLayersDialog.java:438)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog.<init>(SaveLayersDialog.java:93)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog.saveUnsavedModifications(SaveLayersDialog.java:111)
	at org.openstreetmap.josm.Main.lambda$exitJosm$7(Main.java:837)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:9

It seems that it didn't affect anything in JOSM, but I am not sure.

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-23 23:59:49 +0200 (Sun, 23 Jul 2017)
Build-Date:2017-07-24 01:31:50
Revision:12504
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12504 pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 247 MB / 10206 MB (90 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u131-b11-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
+ Create_grid_of_ways (32699)
+ FastDraw (33182)
+ ImportImagePlugin (33372)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ RoadSigns (33204)
+ SimplifyArea (33004)
+ apache-commons (32994)
+ buildings_tools (33004)
+ conflation (0.5.4)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geojson (52)
+ geotools (33380)
+ importvec (33088)
+ indoorhelper (33088)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33436)
+ opendata (33438)
+ pbf (33241)
+ pdfimport (33004)
+ poly (33004)
+ reverter (33088)
+ scripting (30768)
+ tageditor (33021)
+ todo (30200)
+ turnlanes (33294)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ undelete (33374)
+ utilsplugin2 (33328)

Attachments (0)

Change History (6)

comment:1 Changed 8 weeks ago by Don-vip

Milestone: 17.07

why do you think it's related to ipv6? It seems unrelated.

comment:2 Changed 8 weeks ago by naoliv

Wild guess is because it happened after testing the IPv6 connectivity.
It seems that it didn't detect a good IPv6 connection, tried to restart (but somehow failed) and kept loading JOSM.
At least reading this seems to match what I could see:

	at org.openstreetmap.josm.Main.exitJosm(Main.java:836)
	at org.openstreetmap.josm.actions.RestartAction.restartJOSM(RestartAction.java:87)
	at org.openstreetmap.josm.gui.MainApplication.lambda$checkIPv6$5(MainApplication.java:501)

comment:3 in reply to:  2 ; Changed 8 weeks ago by stoecker

Replying to naoliv:

Wild guess is because it happened after testing the IPv6 connectivity.
It seems that it didn't detect a good IPv6 connection, tried to restart (but somehow failed) and kept loading JOSM.
At least reading this seems to match what I could see:

	at org.openstreetmap.josm.Main.exitJosm(Main.java:836)
	at org.openstreetmap.josm.actions.RestartAction.restartJOSM(RestartAction.java:87)
	at org.openstreetmap.josm.gui.MainApplication.lambda$checkIPv6$5(MainApplication.java:501)

In this case it is probably Restart-related. Does this also happen when you cause a restart of JOSM any other way?

comment:4 in reply to:  3 Changed 8 weeks ago by naoliv

Replying to stoecker:

In this case it is probably Restart-related. Does this also happen when you cause a restart of JOSM any other way?

I don't know.
When I ask to restart it doesn't output anything else to console.
I need to see if there is a way to take a look at the messages after restarting.

comment:5 Changed 8 weeks ago by bastiK

The NPE seems plausible as Main.mainPanel is not yet initialized when checkIPv6() is called.

comment:6 Changed 8 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 12507/josm:

fix #15062 - avoid NPE when restarting JOSM

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.