Modify

Opened 2 weeks ago

Closed 2 weeks ago

Last modified 4 days ago

#15016 closed defect (fixed)

Select "Layer" with no data loaded (Bing background) results in Crash

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 17.07
Component: Core Version:
Keywords: template_report autofilter regression Cc:

Description

What steps will reproduce the problem?

  1. participate in MapRoulette in some part of Berlin & load data via "R" into JOSM
  2. do stuff, upload to OSM and delete layer (garbage icon)
  3. click on the "8" / "7" layer filter that is still visible (also no data layer is loaded anymore) -> crash

What is the expected result?

No layer filter to click on/no crash

What happens instead?

Crash/Error report window

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-03 00:44:07 +0200 (Mon, 03 Jul 2017)
Build-Date:2017-07-02 23:26:36
Revision:12450
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12450 de) Linux Arch Linux
Memory Usage: 1431 MB / 1753 MB (623 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1680x1050, :0.1 1280x1024
Maximum Screen Size: 1680x1050

Plugins:
+ Mapillary (v1.5.5)
+ PicLayer (33385)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ jogl (1.0.46)
+ log4j (32699)
+ measurement (33088)
+ public_transport (33166)
+ reverter (33088)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/OpenStationMap&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1

Last errors/warnings:
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- W: RemoteControl: invalid selection '' ignored: java.lang.IllegalArgumentException: The string  does not match the pattern (n|node|w|way|r|rel|relation)[ /]?(\d+)
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.autofilter.AutoFilterManager.setCurrentAutoFilter(AutoFilterManager.java:356)
	at org.openstreetmap.josm.gui.autofilter.AutoFilterButton$1.actionPerformed(AutoFilterButton.java:40)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (4)

comment:1 Changed 2 weeks ago by Don-vip

Keywords: autofilter regression added
Milestone: 17.07
Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 12471/josm:

fix #15016 - NPE

comment:3 Changed 2 weeks ago by Don-vip

In 12472/josm:

see #15016 - avoid spurious remotecontrol warnings with empty parameters

comment:4 Changed 4 days ago by Don-vip

Ticket #15048 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.