Modify

Opened 2 months ago

Closed 2 months ago

#15014 closed defect (duplicate)

JOSM crashed while doing a CS revert

Reported by: wiki@… Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: Cc:

Description

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-03 00:44:07 +0200 (Mon, 03 Jul 2017)
Build-Date:2017-07-02 23:26:36
Revision:12450
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12450 de) Linux Debian GNU/Linux 9.0 (stretch)
Memory Usage: 3243 MB / 3641 MB (3080 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: openjdk-8-jre:amd64-8u131-b11-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (33182)
+ FastDraw (33182)
+ Mapillary (v1.5.5)
+ PicLayer (33385)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ continuosDownload (53)
+ contourmerge (1030)
+ download_along (32946)
+ livegps (33420)
+ measurement (33088)
+ reverter (33088)
+ terracer (33088)
+ undelete (33374)
+ utilsplugin2 (33328)

Tagging presets:
+ <josm.pref>/eigene-vorlagen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- E: Fehler beim Laden des Bildes '<josm.pref>/icons/track1.png'
- W:  Track: Could not get presets icon <josm.pref>/icons/track1.png
- E: Fehler beim Laden des Bildes 'presets/wall.png'
- W:  Mauern: Could not get presets icon presets/wall.png
- E: Handled by bug report queue: java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 2.881.575.145 nicht gefunden


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (17) of main
java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 2.881.575.145 nicht gefunden
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:62)
	at reverter.DataSetCommandMerger.mergeNode(DataSetCommandMerger.java:82)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:173)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:46)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:350)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:112)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (1)

comment:1 Changed 2 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13981.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.