Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#15013 closed enhancement (fixed)

Remember projection after restart

Reported by: Polarbear-j Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: projection regression Cc:

Description

v12450 introduced resetting projection to default, and a new "set as default" button.

This might be nice for people who only rarely use a different projection, but is a regression when you regularly switch between them.

Yes there is imagery reprojection now, but I prefer to do my bulk work in the native projection of my imagery, for precision and performance issues.

So the reasons for restarting JOSM and for changing the projection are not the same. I need to continue in the same projection as I have closed JOSM with. So having any projection set as default is counter-productive.

Even worse, the preselected EPSG value in "By Code EPSG" is reset to Mercator (or probably what I set as the default projection).

So, please provide beside "set as default" the opposite of "remember last projection after restart".

In this context, I find that #7592 (fast switch projections) was closed prematurely in the reprojection euphoria, and it would be good to allow the display of the current projection in the bottom bar, at least in expert mode.

Attachments (0)

Change History (7)

comment:1 in reply to:  description Changed 2 months ago by bastiK

Replying to Polarbear-j:

v12450 introduced resetting projection to default, and a new "set as default" button.

This might be nice for people who only rarely use a different projection, but is a regression when you regularly switch between them.

Yes there is imagery reprojection now, but I prefer to do my bulk work in the native projection of my imagery, for precision and performance issues.

Please let us know if there are problems with precision (and performance as well)!

So the reasons for restarting JOSM and for changing the projection are not the same. I need to continue in the same projection as I have closed JOSM with. So having any projection set as default is counter-productive.

It is planned to save the projection in the session file. Maybe this would be helpful for you?

Even worse, the preselected EPSG value in "By Code EPSG" is reset to Mercator (or probably what I set as the default projection).

This is an issue, I'm willing to look into.

So, please provide beside "set as default" the opposite of "remember last projection after restart".

I would prefer to keep the GUI clean and simple. The "set as default" button is already a concession to advanced users. Having a plethora of exotic and rarely used options is kinda "the JOSM way", but I don't like it all that much. Why don't you just click the "set as default" button each time you change the projection? We cannot cater to the specific conveniences of every power user.

comment:2 Changed 2 months ago by Polarbear-j

Please let us know if there are problems with precision (and performance as well)

I am still evaluating the precision, however depending on the system load, the extra step of reprojecting is sometimes visible.

It is planned to save the projection in the session file. Maybe this would be helpful for you?

Helpful indeed, as I save a couple of imagery layers as a session. Talking about sessions, a dialogue at josm start "Would you like to restore the previous session?", or a list of recent sessions, would be a good idea.

preselected EPSG value in "By Code EPSG" issue / willing to look into

thanks

keep the GUI clean and simple.

understood.

comment:3 in reply to:  2 Changed 2 months ago by Klumbumbus

Replying to Polarbear-j:

Talking about sessions, a dialogue at josm start "Would you like to restore the previous session?", or a list of recent sessions, would be a good idea.

It is in File -> Open Recent

it would be good to allow the display of the current projection in the bottom bar, at least in expert mode

Maybe this could be integrated in "profiles", see #11914

comment:4 Changed 2 months ago by Don-vip

Keywords: projection regression added
Type: defectenhancement

comment:5 Changed 2 months ago by Polarbear-j

It is in File -> Open Recent

Yes I know, but many modern applications offer to reopen a session (semi)automatically.

current projection --> "profiles"

good idea, anywhere where I see it on first glance.

comment:6 Changed 2 months ago by bastiK

Resolution: fixed
Status: newclosed

In 12485/josm:

remember projection choice sub-preferences (e.g. last selected UTM zone) across sessions (not just when changing the default projection) (closes #15013, see #14877)

comment:7 Changed 2 months ago by bastiK

In 12486/josm:

see #15013, see #14877 - remember projection when session is saved to a .jos/.joz file

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.