Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#14980 closed defect (fixed)

Path rendering shows only dashed green line with foot- and cycleway tagged

Reported by: riiga_92@… Owned by: team
Priority: blocker Milestone: 17.06
Component: Core mappaint Version:
Keywords: template_report regression Cc: michael2402, bastiK

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Draw a line
  2. Apply the foot- and cycleway preset
  3. Zoom in, or drag the view so it not in the center of the screen

What is the expected result?

Path rendered as purple-green dashed line

What happens instead?

Path renders as dashed green line, no purple to indicate bicycle=designated

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-06-30 21:29:41 +0200 (Fri, 30 Jun 2017)
Build-Date:2017-06-30 19:32:34
Revision:12443
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12443 en) Windows 7 64-Bit
OS Build number: Windows 7 Ultimate (7601)
Memory Usage: 907 MB / 910 MB (571 MB allocated, but free)
Java version: 1.8.0_31-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (33160)
+ FixAddresses (33182)
+ Mapillary (v1.5.5)
+ PicLayer (33385)
+ apache-commons (32994)
+ apache-http (32699)
+ areaselector (1489184284)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33380)
+ imagery_offset_db (33316)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ opendata (33358)
+ pt_assistant (33362)
+ reverter (33088)
+ tageditor (33021)
+ terracer (33088)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ utilsplugin2 (33328)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Before:
Before

After:
After

Attachments (2)

josm-rendering-1.png (40.7 KB) - added by riiga_92@… 5 months ago.
Before
josm-rendering-2.png (49.1 KB) - added by riiga_92@… 5 months ago.
After

Download all attachments as: .zip

Change History (15)

Changed 5 months ago by riiga_92@…

Attachment: josm-rendering-1.png added

Before

Changed 5 months ago by riiga_92@…

Attachment: josm-rendering-2.png added

After

comment:1 Changed 5 months ago by riiga_92@…

If you zoom in real close you can see some purple pixels in the image, maybe both lines render on top of each other and not odd-even.

comment:2 Changed 5 months ago by Klumbumbus

Cc: michael2402 added
Component: CoreCore mappaint
Keywords: regression added
Priority: normalmajor

I noticed this too today when selecting railways.

This happens when the start node of the way is out of the mapview.

comment:3 Changed 5 months ago by michael2402

Is this new? It seems to be a problem with clamping. And the clamping code is several months old, so we might have this issue for quite some time now.

comment:4 Changed 5 months ago by Klumbumbus

Cc: bastiK added

regression somewhere between 12389 and 12400 (maybe r12399?)

comment:5 Changed 5 months ago by bastiK

Probably collateral damage of [12399]. Michael, could you have a look? Ideally the repeat-image-phase and the dashes-background feature should both work at the same time.

comment:6 Changed 5 months ago by michael2402

I'll have a look at it the next days. Should not be hard, probably some sign issue.

comment:7 Changed 5 months ago by bastiK

In 12448/josm:

extend test case for MapCSSRendererTest (see #14980)

comment:8 Changed 5 months ago by Don-vip

Description: modified (diff)

comment:9 Changed 5 months ago by Don-vip

Milestone: 17.07

comment:10 Changed 5 months ago by Klumbumbus

I think we should release a hotfix for this. Railways look strange (only white stripes and the selection is nearly invisible) and their start node is most of the time out of the mapview as railways are often long ways.

comment:11 Changed 5 months ago by bastiK

Resolution: fixed
Status: newclosed

In 12450/josm:

revert [12399], fixes #14980, reopens #14926

comment:12 Changed 5 months ago by Don-vip

r12450 released as hotfix.

comment:13 Changed 5 months ago by Klumbumbus

Milestone: 17.0717.06
Priority: majorblocker

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.