Modify

Opened 6 months ago

Closed 6 months ago

#14945 closed defect (fixed)

InvalidPathException at startup when invalid URL is registered for map paint style

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.06
Component: Core Version:
Keywords: template_report url Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 en) Windows 7 64-Bit
OS Build number: Windows 7 Enterprise null (7601)
Memory Usage: 141 MB / 989 MB (81 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ AddrInterpolation
+ CADTools
+ ColorPlugin
+ DirectDownload
+ DirectUpload
+ ImageWayPoint
+ ImportImagePlugin
+ ImproveOsm (110)
+ OpenStreetCam
+ PicLayer
+ SeaMapEditor
+ ShapeTools
+ apache-commons
+ buildings_tools
+ continuosDownload
+ ejml
+ geochat
+ geojson
+ geotools
+ imagery_offset_db
+ jogl
+ jts
+ kendzi3d
+ kendzi3d-resources
+ log4j (32699)
+ measurement
+ opendata
+ osm-obj-info
+ osmarender
+ photo_geotagging
+ tageditor
+ tagging-preset-tester
+ turnrestrictions
+ utilsplugin2
+ walkingpapers
+ wikipedia

Tagging presets:
+ http://dev.openseamap.org/josm/Presets_Hafen.xml
+ http://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&preset
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&zip=1
-  http://osm.wzh.be/josm/entur.mapcss

Last errors/warnings:
- E: Failed to locate image 'presets/marina.png'
- W:  Harbour: Could not get presets icon presets/marina.png
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.nio.file.InvalidPathException: Illegal char <:> at index 5:  http:\osm.wzh.be\josm. Cause: java.util.concurrent.ExecutionException: java.nio.file.InvalidPathException: Illegal char <:> at index 5:  http:\osm.wzh.be\josm. Cause: java.nio.file.InvalidPathException: Illegal char <:> at index 5:  http:\osm.wzh.be\josm


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.nio.file.InvalidPathException: Illegal char <:> at index 5:  http:\osm.wzh.be\josm
	at org.openstreetmap.josm.Main.initialize(Main.java:571)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:359)
Caused by: java.util.concurrent.ExecutionException: java.nio.file.InvalidPathException: Illegal char <:> at index 5:  http:\osm.wzh.be\josm
	at java.util.concurrent.FutureTask.report(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.initialize(Main.java:563)
	... 1 more
Caused by: java.nio.file.InvalidPathException: Illegal char <:> at index 5:  http:\osm.wzh.be\josm
	at sun.nio.fs.WindowsPathParser.normalize(Unknown Source)
	at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
	at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
	at sun.nio.fs.WindowsPath.parse(Unknown Source)
	at sun.nio.fs.WindowsFileSystem.getPath(Unknown Source)
	at java.io.File.toPath(Unknown Source)
	at org.openstreetmap.josm.io.FileWatcher.register(FileWatcher.java:97)
	at org.openstreetmap.josm.io.FileWatcher.registerStyleSource(FileWatcher.java:67)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.loadStyleForFirstTime(MapPaintStyles.java:280)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:270)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:190)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:608)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:592)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 6 months ago by Don-vip

Keywords: url added
Milestone: 17.06
Summary: under startupInvalidPathException at startup when invalid URL is registered for map paint style

comment:2 Changed 6 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12410/josm:

fix #14945 - InvalidPathException at startup when invalid URL is registered for map paint style

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.