Modify

Opened 2 months ago

Closed 2 months ago

#14941 closed defect (duplicate)

Error pops up when deleting last node

Reported by: muzirian Owned by: team
Priority: minor Milestone:
Component: Core Version:
Keywords: delete node Cc:

Description

What steps will reproduce the problem?

  1. Start drawing from a way holding alt
  2. Delete the first node using delete/backspace

What is the expected result?

It should just delete the newly made node and should be able to continue without any errors.

What happens instead?

Error pops up,with option to report bug

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 en) Mac OS X 10.12.3
OS Build number: Mac OS X 10.12.3 (16D30)
Memory Usage: 451 MB / 910 MB (118 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69991240 2560x1440
Maximum Screen Size: 2560x1440
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
+ FastDraw (33182)
+ ImproveWay (12)
+ Mapillary (v1.5.3)
+ OpenStreetCam (81)
+ apache-commons (32994)
+ apache-http (32699)
+ auto_tools (1494971731)
+ buildings_tools (33004)
+ download_along (32946)
+ imagery_offset_db (33316)
+ reverter (33088)
+ terracer (33088)
+ tofix (338)
+ utilsplugin2 (33328)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56499 version=0 MV nodes=[{Node id=-56476 version=0 MV lat=38.714756979705115,lon=-121.60427704721693}, {Node id=-56498 version=0 MV lat=38.71476639646269,lon=-121.60453990235926}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56499 version=0 MV nodes=[{Node id=-56476 version=0 MV lat=38.714756979705115,lon=-121.60427704721693}, {Node id=-56498 version=0 MV lat=38.71476639646269,lon=-121.60453990235926}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56499 version=0 MV nodes=[{Node id=-56476 version=0 MV lat=38.714756979705115,lon=-121.60427704721693}, {Node id=-56498 version=0 MV lat=38.71476639646269,lon=-121.60453990235926}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56499 version=0 MV nodes=[{Node id=-56476 version=0 MV lat=38.714756979705115,lon=-121.60427704721693}, {Node id=-56498 version=0 MV lat=38.71476639646269,lon=-121.60453990235926}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56499 version=0 MV nodes=[{Node id=-56476 version=0 MV lat=38.714756979705115,lon=-121.60427704721693}, {Node id=-56498 version=0 MV lat=38.71476639646269,lon=-121.60453990235926}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56541 version=0 MV nodes=[{Node id=-56508 version=0 MV lat=38.71575107334509,lon=-121.60577774181964}, {Node id=-56540 version=0 MV lat=38.71575839820199,lon=-121.6054531945288}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56541 version=0 MV nodes=[{Node id=-56508 version=0 MV lat=38.71575107334509,lon=-121.60577774181964}, {Node id=-56540 version=0 MV lat=38.71575839820199,lon=-121.6054531945288}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56541 version=0 MV nodes=[{Node id=-56508 version=0 MV lat=38.71575107334509,lon=-121.60577774181964}, {Node id=-56540 version=0 MV lat=38.71575839820199,lon=-121.6054531945288}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56541 version=0 MV nodes=[{Node id=-56508 version=0 MV lat=38.71575107334509,lon=-121.60577774181964}, {Node id=-56540 version=0 MV lat=38.71575839820199,lon=-121.6054531945288}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-56541 version=0 MV nodes=[{Node id=-56508 version=0 MV lat=38.71575107334509,lon=-121.60577774181964}, {Node id=-56540 version=0 MV lat=38.71575839820199,lon=-121.6054531945288}]}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:252)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:996)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1021)
	at org.openstreetmap.josm.actions.CreateMultipolygonAction.getSelectedMultipolygonRelation(CreateMultipolygonAction.java:184)
	at org.openstreetmap.josm.actions.CreateMultipolygonAction.getSelectedMultipolygonRelation(CreateMultipolygonAction.java:175)
	at org.openstreetmap.josm.actions.CreateMultipolygonAction.updateEnabledState(CreateMultipolygonAction.java:273)
	at org.openstreetmap.josm.actions.JosmAction$SelectionChangeAdapter.selectionChanged(JosmAction.java:386)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$OldListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:203)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:198)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (1)

comment:1 Changed 2 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14854.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.