Modify

Opened 2 months ago

Closed 2 months ago

#14938 closed defect (fixed)

Crash on startup

Reported by: sjoblomj@… Owned by: team
Priority: normal Milestone: 17.06
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

Start JOSM with java -jar josm-tested-12275.jar
This worked yesterday, but today it crashes.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 en) Linux BunsenLabs GNU/Linux 8.4 (Hydrogen)
Memory Usage: 353 MB / 2610 MB (188 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2~bpo8+1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u111-b14-2~bpo8+1

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: elapsedTime must be >= 0. Cause: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: elapsedTime must be >= 0. Cause: java.lang.IllegalArgumentException: elapsedTime must be >= 0


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: elapsedTime must be >= 0
	at org.openstreetmap.josm.Main.initialize(Main.java:571)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:359)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: elapsedTime must be >= 0
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.Main.initialize(Main.java:563)
	... 1 more
Caused by: java.lang.IllegalArgumentException: elapsedTime must be >= 0
	at org.openstreetmap.josm.tools.Utils.getDurationString(Utils.java:923)
	at org.openstreetmap.josm.gui.SplashScreen$MeasurableTask.finish(SplashScreen.java:163)
	at org.openstreetmap.josm.gui.SplashScreen$SplashProgressMonitor.finishTask(SplashScreen.java:297)
	at org.openstreetmap.josm.gui.MainApplication$2.finish(MainApplication.java:343)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:610)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:592)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (2)

comment:1 Changed 2 months ago by Don-vip

Milestone: 17.06

Looks like your system date changed while JOSM was starting...

comment:2 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12405/josm:

fix #14938 - robustness to system date changing during startup

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.