Modify

Opened 4 months ago

Closed 4 months ago

#14933 closed enhancement (fixed)

Roundabout splitter

Reported by: giackserva Owned by: giackserva
Priority: normal Milestone:
Component: Plugin pt_assistant Version:
Keywords: gsoc_pt_assistant roundabout Cc:

Description

when a roundabout made of only one way is added to a public transport relation, it seems like the bus is driving all the way around the roundabout instead of just a portion of it. a useful command would perform the following operations on a selected roundabout:

  • download bbox to make sure all the ways connecting to the roundabout are present
  • find points to split roundabout way(s)
  • ask user if it's OK to make roundabout round
  • loop over all route relations and repair them

Attachments (0)

Change History (7)

comment:1 Changed 4 months ago by Don-vip

Keywords: roundabout added

comment:2 Changed 4 months ago by giackserva

Type: defectenhancement

comment:3 Changed 4 months ago by giackserva

Resolution: fixed
Status: assignedclosed

comment:4 Changed 4 months ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:5 Changed 4 months ago by giackserva

Tests succeed when launched locally, sorry I didn't check jenkins.
At first sight, I have no clue why that is happenings.
At second sight I realized the problem is that the layer manager is trying to delete a null layer. The only place where I delete the layer is at the end of the each test, so perhaps the content of the variable layer gets canceled in the meantime.
Still no idea why that doesn't happen locally.
Any suggestions?

Last edited 4 months ago by giackserva (previous) (diff)

comment:6 Changed 4 months ago by Don-vip

Should be fixed in [o33412]. The unit tests didn't work for me in my Eclipse.

Last edited 4 months ago by Don-vip (previous) (diff)

comment:7 Changed 4 months ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain giackserva.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.