Modify

Opened 6 weeks ago

Closed 6 weeks ago

#14932 closed defect (duplicate)

attempts to upload then fails, previous to this error upload stops with a api failure and try again notice

Reported by: alan.ruth.bragg@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 482 MB / 989 MB (66 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (33182)
+ FixAddresses (33182)
+ HouseNumberTaggingTool (33160)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ auto_tools (1494971731)
+ buildings_tools (33004)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geotools (33338)
+ jts (32699)
+ measurement (33088)
+ merge-overlap (33154)
+ opendata (33356)
+ tag2link (33035)
+ utilsplugin2 (33328)
+ waydownloader (33167)
+ wikipedia (33288)

Tagging presets:
+ %UserProfile%\Documents\driveway.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
+ https://github.com/gmgeo/osmic-josm-style/archive/master.zip

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: Handled by bug report queue: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- W: 1 problems occured during upload/save


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
	at org.openstreetmap.josm.io.OsmApi.sleepAndListen(OsmApi.java:560)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:658)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:600)
	at org.openstreetmap.josm.io.OsmApi.updateChangeset(OsmApi.java:456)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:207)
	at org.openstreetmap.josm.gui.io.UploadLayerTask.run(UploadLayerTask.java:124)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 6 weeks ago by alan.ruth.bragg@…

The only way I've found to recover is to save the osm file. exit josm. restart josm and open and save the file.

comment:2 Changed 6 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14898.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.