Modify

Opened 7 months ago

Closed 7 months ago

#14849 closed defect (fixed)

IllegalStateException: This tasks has already been finished (Crash at startup)

Reported by: anonymous Owned by: team
Priority: major Milestone: 17.05
Component: Core Version:
Keywords: template_report regression Cc:

Description (last modified by Don-vip)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 00:35:21 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-28 22:37:41
Revision:12271
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12271 sk) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 431 MB / 910 MB (241 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200, \Display1 1920x1200
Maximum Screen Size: 1920x1200

Plugins:
+ turnrestrictions

Last errors/warnings:
- W: Aktualizácia pluginov - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: This tasks has already been finished. Príčina: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: This tasks has already been finished. Príčina: java.lang.IllegalStateException: This tasks has already been finished


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: This tasks has already been finished
	at org.openstreetmap.josm.Main.initialize(Main.java:571)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:359)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: This tasks has already been finished
	at java.util.concurrent.FutureTask.report(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.initialize(Main.java:563)
	... 1 more
Caused by: java.lang.IllegalStateException: This tasks has already been finished
	at org.openstreetmap.josm.gui.SplashScreen$MeasurableTask.finish(SplashScreen.java:161)
	at org.openstreetmap.josm.gui.SplashScreen$SplashProgressMonitor.finishTask(SplashScreen.java:288)
	at org.openstreetmap.josm.gui.MainApplication$2.finish(MainApplication.java:343)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:610)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:592)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 7 months ago by Don-vip

Description: modified (diff)
Keywords: regression added
Priority: normalmajor
Summary: Crash at startup - new instalationIllegalStateException: This tasks has already been finished (Crash at startup)

comment:2 Changed 7 months ago by Don-vip

Milestone: 17.05

comment:3 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12272/josm:

fix #14849 - fix crash at startup when two initialization tasks have been translated with the same text

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.