Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#14847 closed defect (fixed)

GPS layer settings glitch

Reported by: bielebog Owned by: team
Priority: major Milestone: 17.05
Component: Core Version:
Keywords: template_report gpx regression Cc: michael2402

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Download GPS tracks with OSM data through download dialogue
  2. Download GPS tracks show just fine in layer "downloaded GPS data", layer settings like transparency apply.
  3. Now download some more GPS tracks

What is the expected result?

The additional GPS tracks are shown in the same layer just as the data previously downloaded, and behave just the same.

What happens instead?

The already existing GPS data is shown unchanged and the newly downloaded GPS data is shown
in another style as points with default style. Layer settings don't apply to all data in the
GPS data layer.

Please provide any additional information below. Attach a screenshot if possible.

See https://flic.kr/p/V24J3d and https://flic.kr/p/V24GWq

https://c1.staticflickr.com/5/4273/34798951952_332fde0557_b.jpg

https://c1.staticflickr.com/5/4222/34798948252_c51dd1f869_b.jpg

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-25 19:01:20 +0200 (Thu, 25 May 2017)
Build-Date:2017-05-25 17:05:15
Revision:12256
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12256 de) Linux Ubuntu 14.04.5 LTS
Memory Usage: 1060 MB / 1753 MB (497 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-3~14.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1280x800, :0.1 1680x1050
Maximum Screen Size: 1680x1050
Java package: openjdk-8-jre:amd64-8u111-b14-3~14.04.1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.4-4
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (32699)
+ DirectDownload (33160)
+ DirectUpload (33182)
+ ElevationProfile (33215)
+ FixAddresses (33182)
+ HouseNumberTaggingTool (33160)
+ Mapillary (v1.5.3)
+ PicLayer (33148)
+ RoadSigns (33204)
+ Tracer2 (33004)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ conflation (0.5.4)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geochat (33088)
+ geotools (33042)
+ gpsblam (33258)
+ gpxfilter (33004)
+ graphview (33004)
+ imagery_offset_db (33316)
+ jna (32699)
+ jogl (1.0.46)
+ jts (32699)
+ kendzi3d (1.0.195)
+ kendzi3d-resources (0.0.1)
+ livegps (33138)
+ log4j (32699)
+ measurement (33088)
+ opendata (33245)
+ osmarender (33004)
+ pbf (33241)
+ pdfimport (33004)
+ photo_geotagging (33088)
+ photoadjust (33303)
+ print (33260)
+ public_transport (33166)
+ public_transport_layer (33088)
+ rasterfilters (33269)
+ reltoolbox (33311)
+ reverter (33088)
+ tag2link (33035)
+ tageditor (33021)
+ terracer (33088)
+ turnlanes (33294)
+ undelete (33263)
+ utilsplugin2 (33328)
+ wikipedia (33288)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ http://osmtools.de/josm/steps.xml
+ http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/SkiingTrail&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ http://www.openrailwaymap.org/josm-presets/de.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/caravan_site&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ ${HOME}/josm/presets/surveillance_preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1
+ http://www.country-linedance.de/daten/Archaeologie-de.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Animal_facilities&zip=1
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Surveillance&zip=1
+ https://raw.github.com/Flacus/Windrad/master/windrad.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BloodDonation&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Ph_Typhoon&zip=1
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1

Last errors/warnings:
- E: No tagging preset submenu for  RoadSigns
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for  RoadSigns
- E: No tagging preset submenu for  RoadSigns
- E: No tagging preset submenu for  RoadSigns
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for

Attachments (0)

Change History (9)

comment:1 Changed 5 months ago by Don-vip

Cc: michael2402 added
Description: modified (diff)
Keywords: gpx regression added

comment:2 Changed 5 months ago by Don-vip

regression from r12155:12157 + r12195?

comment:3 Changed 5 months ago by Don-vip

Milestone: 17.05

comment:4 Changed 5 months ago by Don-vip

Priority: normalmajor

comment:5 Changed 5 months ago by Don-vip

or maybe r12170

comment:6 Changed 5 months ago by michael2402

Resolution: fixed
Status: newclosed

In 12274/josm:

Fix #14847: Fix reload of colors if data was added to/removed from gpx layer.

comment:7 Changed 5 months ago by michael2402

It was r12157. After moving all the paint-related stuff to the draw helper, the data update event was not received any more.

comment:8 Changed 5 months ago by Don-vip

In 12275/josm:

see #14847 - optimization during gpx parsing: don't construct change event objects each time a track is added if there is no listener yet

comment:9 Changed 5 months ago by Don-vip

Thanks! I was trying to resolve it but it's not easy when you don't know the code in detail :) I'm going to re-release 17.05 now (because of the two crashes at start, not this one).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.