Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#14810 closed defect (fixed)

java.lang.UnsupportedOperationException

Reported by: dieterdreist Owned by: team
Priority: blocker Milestone: 17.05
Component: Core Version:
Keywords: template_report regression Cc: michael2402

Description

What steps will reproduce the problem?

  1. start josm
  2. draw a way

What is the expected result?

normal operation

What happens instead?

unhandled error

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-16 00:07:12 +0200 (Tue, 16 May 2017)
Build-Date:2017-05-16 01:32:08
Revision:12192
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12192 en) Mac OS X 10.11.6
Memory Usage: 866 MB / 1820 MB (426 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188875522 1920x1080, Display 458628992 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ PicLayer (33148)
+ SimplifyArea (33004)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ fieldpapers (v0.4.1)
+ geochat (33088)
+ geotools (33042)
+ imagery_offset_db (33309)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ opendata (33245)
+ photo_geotagging (33088)
+ print (33260)
+ reltoolbox (33311)
+ reverter (33088)
+ undelete (33263)
+ utilsplugin2 (33297)
+ wikipedia (33288)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- E: Handled by bug report queue: java.lang.UnsupportedOperationException
- E: Handled by bug report queue: java.lang.UnsupportedOperationException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.UnsupportedOperationException
	at java.util.Collections$UnmodifiableCollection.add(Collections.java:1055)
	at org.openstreetmap.josm.data.osm.Way.save(Way.java:311)
	at org.openstreetmap.josm.command.Command$CloneVisitor.visit(Command.java:61)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:211)
	at org.openstreetmap.josm.command.Command.executeCommand(Command.java:188)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:80)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:65)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:53)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:81)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:613)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (7)

comment:1 Changed 2 months ago by Don-vip

Cc: michael2402 added
Keywords: regression added
Milestone: 17.05
Priority: normalblocker

blocking regression from r12190

comment:2 Changed 2 months ago by Don-vip

And jenkins job has been failing all day because of this error.

comment:3 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12193/josm:

fix #14810 - partial revert of r12190

comment:4 Changed 2 months ago by Don-vip

Ticket #14809 has been marked as a duplicate of this ticket.

comment:5 Changed 2 months ago by Don-vip

I have manually released r12193 as new latest. I'm surprised to not see more than two tickets for this bug.

comment:6 Changed 2 months ago by michael2402

I'm sorry. I did some editing with it yesterday after that change (to test more DrawAction issues) but did not hit this one.

comment:7 Changed 2 months ago by alexkemp

Fixed now, thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.