Modify

Opened 2 weeks ago

Closed 13 days ago

#14792 closed defect (fixed)

Preferences file is overwritten at start up

Reported by: hjart Owned by: hjart
Priority: normal Milestone: 17.05
Component: Core Version: latest
Keywords: template_report version regression Cc:

Description

Latest currently appears to destroy existing preferences at start up

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-13 01:44:23 +0200 (Sat, 13 May 2017)
Build-Date:2017-05-13 01:32:35
Revision:12133
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12133 da) Linux openSUSE Leap 42.2
Memory Usage: 366 MB / 1324 MB (237 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: openjdk-8-jre:pakken openjdk-8-jre er ikke installeret

Attachments (0)

Change History (6)

comment:1 Changed 2 weeks ago by Don-vip

Owner: changed from team to hjart
Status: newneedinfo

Works for me, and AFAIK we didn't change anything in the preferences system recently. How do you launch JOSM?

comment:2 Changed 2 weeks ago by hjart

Via a bash script which worked fine until this morning. Just running "java -jar josm-latest.jar works fine. Weird. Maybe some update to my OS messed things up.

comment:3 Changed 2 weeks ago by Don-vip

Resolution: othersoftware
Status: needinfoclosed

comment:4 Changed 13 days ago by hjart

Resolution: othersoftware
Status: closedreopened

My bash script checks the --version of JOSM "java -jar josm-latest.jar --version". Until yesterday morning JOSM would then just print the version then exit, which was exactly what I wanted. Now it makes JOSM start up in a state which appears to not recognize existing preferences. Same thing happens when running "java -jar josm-latest.jar --help"

What I see now in console when running "java -jar josm-latest.jar --version":

JOSM/1.5 (12133 da) Linux openSUSE Leap 42.2
2017-05-15 09:40:10.858 INFO: GET https://josm.openstreetmap.de/wiki/Da:StartupPage -> 200
2017-05-15 09:40:11.290 INFO: GET https://api.openstreetmap.org/api/capabilities -> 200 (434 B)
2017-05-15 09:40:11.291 INFO: OK
2017-05-15 09:40:11.320 INFO: GET https://josm.openstreetmap.de/maps -> 200
[INFO] CompositeCacheManager - Instance is null, returning unconfigured instance
[WARN] ThreadPoolManager - No configuration settings found.  Using hardcoded default values for all pools.
[INFO] CompositeCacheManager - Setting default auxiliaries to null
[INFO] CompositeCacheManager - setting defaultCompositeCacheAttributes to [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
[INFO] CompositeCacheManager - setting defaultElementAttributes to [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = false, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1494834013300, LastAccessTime = 1494834013300, getTimeToLiveSeconds() = -1, createTime = 1494834013300 ]
[INFO] CompositeCacheConfigurator - Parsed regions []
[INFO] CompositeCacheManager - Finished configuration in 50 ms.
[INFO] CompositeCacheConfigurator - No special ElementAttribute class defined for key [jcs.region.TMS.elementattributes], using default class.
[INFO] AbstractDoubleLinkedListMemoryCache - initialized MemoryCache for TMS
[INFO] CompositeCache - Constructed cache with name [TMS] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 0, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
[INFO] BlockDiskCache - Region [TMS_BLOCK_v2] Constructing BlockDiskCache with attributes 
BlockDiskAttributes 
 DiskPath [/home/hjart/.josm/cache/tiles]
 MaxKeySize [524288]
 MaxPurgatorySize [5000]
 BlockSizeBytes [4096]
 KeyPersistenceIntervalSeconds [300]
 DiskLimitType [SIZE]
[INFO] BlockDiskCache - Region [TMS_BLOCK_v2] Cache file root directory: [/home/hjart/.josm/cache/tiles]
[INFO] BlockDisk - Constructing BlockDisk, blockSizeBytes [4096]
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Cache file root directory [/home/hjart/.josm/cache/tiles]
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Key File [/home/hjart/.josm/cache/tiles/TMS_BLOCK_v2.key]
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Loading keys for /home/hjart/.josm/cache/tiles/TMS_BLOCK_v2.key
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Set maxKeySize to: '524288'
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Loaded keys from [TMS_BLOCK_v2], key count: 22325; up to 524288 will be available.
[INFO] BlockDiskCache - Region [TMS_BLOCK_v2] Block Disk Cache is alive.
[INFO] ElementEventQueue - Element event queue destroyed: org.apache.commons.jcs.engine.control.event.ElementEventQueue@61370a0
[INFO] CompositeCache - In DISPOSE, [TMS] fromRemote [false]
[INFO] CompositeCache - In DISPOSE, [TMS] auxiliary [TMS_BLOCK_v2]
[INFO] CompositeCache - In DISPOSE, [TMS] put 0 into auxiliary TMS_BLOCK_v2
[INFO] AbstractDiskCache - No longer waiting for event queue to finish: Pooled Cache Event Queue
Working = true
Empty = true
[INFO] AbstractDiskCache - In dispose, destroying event queue.
[INFO] PooledCacheEventQueue - Cache event queue destroyed: CacheEventQueue [listenerId=185361592, cacheName=TMS_BLOCK_v2]
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Saving keys to [/home/hjart/.josm/cache/tiles/TMS_BLOCK_v2.key], key count [22325]
[INFO] BlockDiskKeyStore - Region [TMS_BLOCK_v2] Finished saving keys. It took 141ms. to store 22325 keys.  Key file length [3967810]
[INFO] BlockDiskCache - Region [TMS_BLOCK_v2] Shutdown complete.
[INFO] CompositeCache - In DISPOSE, [TMS] disposing of memory cache.
[INFO] AbstractMemoryCache - Memory Cache dispose called.

Is this due to some weird stuff on my side or in JOSM?

comment:5 Changed 13 days ago by Don-vip

Keywords: version regression added
Milestone: 17.05
Priority: criticalnormal

comment:6 Changed 13 days ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 12150/josm:

fix #14792 - fix --version handling: restore a single main() method

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain hjart.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.