Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#14660 closed defect (worksforme)

custom-epsg - Unable to build latest JOSM with ant

Reported by: TheOutpost Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: custom-epsg ant Cc:

Description

I've checked out the latest commit on mirror on Github:

https://github.com/openstreetmap/josm/commit/d977155fb5b1f54ab76140345633356475f7beee

Now, from a fresh checkout, I run ant. I get the following error:

epsg-compile:

[mkdir] Created dir: /Users/njh/code/josm/build2
[javac] Compiling 1 source file to /Users/njh/code/josm/build2

epsg:

[touch] Creating /Users/njh/code/josm/data/projection/custom-epsg

BUILD FAILED
/Users/njh/code/josm/build.xml:804: Could not create /Users/njh/code/josm/data/projection/custom-epsg

Attachments (0)

Change History (6)

comment:1 Changed 2 months ago by Don-vip

Priority: blockernormal

comment:2 Changed 2 months ago by Don-vip

Resolution: worksforme
Status: newclosed

The Github mirror is not officially supported and often out of date. Please perform a standard SVN checkout as explained on Source code:

svn co https://josm.openstreetmap.de/svn/trunk josm

comment:3 Changed 2 months ago by TheOutpost

Hi Vincent,

The issue is that a fresh checkout does not include the directory data/projection. If I mkdir data/projection before running ant, the build works.

comment:4 Changed 2 months ago by bastiK

This happens because git does not support empty directories.

comment:5 Changed 2 months ago by anonymous

Gotcha. I guess I could start using SVN... It's been years ; )

comment:6 Changed 2 months ago by bastiK

Still, the github mirror can be fixed by placing an empty .gitignore file inside data/projection.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.