Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#14659 closed defect (duplicate)

Errors in Imagery icon loading blocks JOSM when the imagery is displayed in menu

Reported by: stoecker Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

I donwloaded the area around the example in #10529 and JOSM became completely unusable. Here the first two exceptions of a long similar list

2017-04-17 00:18:19.423 INFORMATION: GET https://api.openstreetmap.org/api/0.6/map?bbox=17.5853747,48.3704171,17.5981535,48.3766218 -> 200
2017-04-17 00:18:53.416 INFORMATION: GET http://www.freemap.sk/index.php?c=core.download&filename=/JOSM/freemap.png -> !!!
2017-04-17 00:18:53.418 WARNUNG: java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
        at java.net.SocketInputStream.read(SocketInputStream.java:170)
        at java.net.SocketInputStream.read(SocketInputStream.java:141)
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
        at java.io.BufferedInputStream.read1(BufferedInputStream.java:286)
        at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
        at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:704)
        at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:647)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1569)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1474)
        at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
        at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:129)
        at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:75)
        at org.openstreetmap.josm.io.CachedFile.checkLocal(CachedFile.java:471)
        at org.openstreetmap.josm.io.CachedFile.getFile(CachedFile.java:271)
        at org.openstreetmap.josm.io.CachedFile.getInputStream(CachedFile.java:206)
        at org.openstreetmap.josm.tools.ImageProvider.getIfAvailableHttp(ImageProvider.java:905)
        at org.openstreetmap.josm.tools.ImageProvider.getIfAvailableImpl(ImageProvider.java:809)
        at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:635)
        at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1590)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)

2017-04-17 00:18:53.520 SCHWERWIEGEND: Fehler beim Laden des Bildes 'http://www.freemap.sk/index.php?c=core.download&filename=/JOSM/freemap.png'
2017-04-17 00:19:23.600 INFORMATION: GET http://www.freemap.sk/index.php?c=core.download&filename=/JOSM/freemap.png -> !!!
2017-04-17 00:19:23.601 WARNUNG: java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
        at java.net.SocketInputStream.read(SocketInputStream.java:170)
        at java.net.SocketInputStream.read(SocketInputStream.java:141)
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
        at java.io.BufferedInputStream.read1(BufferedInputStream.java:286)
        at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
        at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:704)
        at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:647)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1569)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1474)
        at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
        at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:129)
        at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:75)
        at org.openstreetmap.josm.io.CachedFile.checkLocal(CachedFile.java:471)
        at org.openstreetmap.josm.io.CachedFile.getFile(CachedFile.java:271)
        at org.openstreetmap.josm.io.CachedFile.getInputStream(CachedFile.java:206)
        at org.openstreetmap.josm.tools.ImageProvider.getIfAvailableHttp(ImageProvider.java:905)
        at org.openstreetmap.josm.tools.ImageProvider.getIfAvailableImpl(ImageProvider.java:809)
        at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:635)
        at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1590)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)

JOSM should not block when external references for Imagery menu cannot be loaded (maybe also affects presets, styles?).

P.S. freemap.sk seems dead?

Attachments (0)

Change History (3)

comment:1 Changed 5 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13809.
Should be fixed. Please add full status report and jstack output if it happens again.

comment:2 in reply to:  description Changed 5 months ago by Klumbumbus

Replying to stoecker:

P.S. freemap.sk seems dead?

Works for me.

comment:3 Changed 5 months ago by Don-vip

Milestone: 17.04

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.