Modify

Opened 8 months ago

Closed 2 months ago

#14624 closed defect (duplicate)

wrong error message from validator

Reported by: dieterdreist Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report multipolygon Cc:

Description

What steps will reproduce the problem?

validation of an outer way with area tags which is also part as "outer" of a multipolygon

What is the expected result?

different error level for "Area style on outer way", e.g. "warning"

What happens instead?

get an "error" but there is nothing wrong

Please provide any additional information below. Attach a screenshot if possible.

example:
http://www.openstreetmap.org/way/483668661
http://www.openstreetmap.org/relation/7141866

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-04-07 01:45:28 +0200 (Fri, 07 Apr 2017)
Build-Date:2017-04-07 01:42:06
Revision:11850
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11850 en) Mac OS X 10.11.6
Memory Usage: 1132 MB / 1820 MB (442 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188875522 1920x1080, Display 458628992 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (33028)
+ OpeningHoursEditor (33185)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ fieldpapers (v0.4.1)
+ geochat (33088)
+ geotools (33042)
+ imagery_offset_db (33004)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ opendata (33197)
+ print (33118)
+ reltoolbox (33088)
+ reverter (33088)
+ undelete (32699)
+ utilsplugin2 (33212)
+ wikipedia (33098)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 19.  Encountered: "t" (116), after : ""
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Cause: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 19.  Encountered: "t" (116), after : ""
- W: org.openstreetmap.josm.plugins.ohe.parser.ParseException: Encountered " <WEEKDAY> "Th "" at line 1, column 19.
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Cause: org.openstreetmap.josm.plugins.ohe.parser.ParseException: Encountered " <WEEKDAY> "Th "" at line 1, column 19.
- W: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 19.  Encountered: "T" (84), after : ";"
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Cause: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 19.  Encountered: "T" (84), after : ";"
- W: org.openstreetmap.josm.plugins.ohe.parser.ParseException: Encountered " ":" ": "" at line 1, column 24.
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Cause: org.openstreetmap.josm.plugins.ohe.parser.ParseException: Encountered " ":" ": "" at line 1, column 24.
- W: org.openstreetmap.josm.plugins.ohe.parser.ParseException: Encountered " ":" ": "" at line 1, column 30.
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Cause: org.openstreetmap.josm.plugins.ohe.parser.ParseException: Encountered " ":" ": "" at line 1, column 30.

Attachments (1)

14624.osm (2.9 KB) - added by Don-vip 2 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 8 months ago by Don-vip

Keywords: multipolygon added

comment:2 Changed 6 months ago by Klumbumbus

pretty much a duplicate of #12385 I think

Changed 2 months ago by Don-vip

Attachment: 14624.osm added

comment:3 Changed 2 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12385.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.