Modify

Opened 3 months ago

Closed 2 months ago

#14623 closed defect (duplicate)

CCE: javax.json.JsonValue$1 cannot be cast to javax.json.JsonString

Reported by: gary27gary@… Owned by: Nipel-Crumple
Priority: normal Milestone:
Component: Plugin rasterfilters Version:
Keywords: template_report json Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. me sale este error al abrir un archivo osm
URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 es) Windows 7 64-Bit
Memory Usage: 484 MB / 989 MB (158 MB allocated, but free)
Java version: 1.8.0_25-b18, Oracle Corporation, Java HotSpot(TM) Client VM

Plugins:
- apache-commons (32584)
- ejml (32639)
- geotools (32584)
- jts (32539)
- opendata (32158)
- rasterfilters (32503)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: Ha ocurrido un error en el complemento rasterfilters. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.layer.MainLayerManager.addActiveLayerChangeListener(Lorg/openstreetmap/josm/gui/layer/MainLayerManager$ActiveLayerChangeListener;)V
- E: java.lang.ClassCastException: javax.json.JsonValue$1 cannot be cast to javax.json.JsonString

java.lang.ClassCastException: javax.json.JsonValue$1 cannot be cast to javax.json.JsonString
	at org.glassfish.json.JsonObjectBuilderImpl$JsonObjectImpl.getJsonString(JsonObjectBuilderImpl.java:194)
	at org.glassfish.json.JsonObjectBuilderImpl$JsonObjectImpl.getString(JsonObjectBuilderImpl.java:199)
	at org.openstreetmap.josm.plugins.rasterfilters.preferences.FiltersDownloader.downloadFiltersInfoList(FiltersDownloader.java:102)
	at org.openstreetmap.josm.plugins.rasterfilters.RasterFiltersPlugin.layerAdded(RasterFiltersPlugin.java:85)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerAdded(LayerManager.java:329)
	at org.openstreetmap.josm.gui.layer.LayerManager.realAddLayer(LayerManager.java:150)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realAddLayer(MainLayerManager.java:167)
	at org.openstreetmap.josm.gui.layer.LayerManager$1.run(LayerManager.java:137)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:144)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:134)
	at org.openstreetmap.josm.Main.addLayer(Main.java:794)
	at org.openstreetmap.josm.Main.addLayer(Main.java:776)
	at org.openstreetmap.josm.io.OsmImporter$1.run(OsmImporter.java:104)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$400(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:502)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:289)
	at org.openstreetmap.josm.tools.bugreport.BugReportExceptionHandler$BugReporterThread.askForBugReport(BugReportExceptionHandler.java:127)
	at org.openstreetmap.josm.tools.bugreport.BugReportExceptionHandler$BugReporterThread$BugReporterWorker.run(BugReportExceptionHandler.java:60)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$400(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:197)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$400(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 3 months ago by Don-vip

Component: CorePlugin rasterfilters
Description: modified (diff)
Keywords: json added
Owner: changed from team to Nipel-Crumple
Summary: me sale este error al abrir un archivo osmCCE: javax.json.JsonValue$1 cannot be cast to javax.json.JsonString

comment:2 Changed 2 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13419.
Fixed 3 months ago, please update your version of JOSM and its plugins.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Nipel-Crumple.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.