Modify

Opened 9 months ago

Closed 3 months ago

Last modified 3 months ago

#14578 closed enhancement (fixed)

[Patch] Use osmhv as external history viewer

Reported by: jengelh@… Owned by: team
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: history changeset Cc:

Description

Pressing Ctrl-H gives a dialog box "History for way 45175455". In this dialog box, clicking on the changeset ID opens, in an external browser, the URL

http://www.openstreetmap.org/changeset/45175455

I suggest to change the default to

http://osmhv.openstreetmap.de/changeset.jsp?id=45175455

(Applies to any object, not specifically 45175455.)

Attachments (5)

buttonhistoryviewer.png (18.0 KB) - added by Klumbumbus 9 months ago.
14578.patch (3.7 KB) - added by simon04 5 months ago.
Screenshot_20170728_224505.png (10.8 KB) - added by simon04 5 months ago.
Screenshot_20170917_122942.png (10.2 KB) - added by simon04 3 months ago.
Screenshot_20170917_123054.png (11.7 KB) - added by simon04 3 months ago.

Download all attachments as: .zip

Change History (29)

comment:1 Changed 9 months ago by stoecker

Milestone: 17.04

Not as a replacement, but additionally I'd agree. It is a very good display of the changes.

comment:2 Changed 9 months ago by bastiK

Achavi is also quite nice, if not better: http://overpass-api.de/achavi/?changeset=45175455

comment:3 Changed 9 months ago by Klumbumbus

I also use achavi when analyzing changesets. We could add a achavi button in the history viewer beside the changeset button.

comment:4 Changed 9 months ago by Don-vip

Keywords: history changeset added

comment:5 Changed 9 months ago by stoecker

What about a configuration option choosing one of the three then? Probably better than adding multiple buttons.

comment:6 Changed 9 months ago by Klumbumbus

Hm, I don't want to decide on one of them. The josm history viewer is also very helpful and can present some things better than e.g. achavi (e.g. changes on relations)

Also the josm history viewer is for displaying changes of a single object, while other sites like achavi present changes of whole changesets. So achavi is more like an alternative for the josm Help/Dialog/ChangesetManager (but would be nice if it is linked in the history browser)

Last edited 9 months ago by Klumbumbus (previous) (diff)

comment:7 Changed 9 months ago by stoecker

What about a setting in prefs for the default and the small arrow button (like for search) for additionally choosing the final one?

@Klumbumbus: What do you mean? We don't want to replace JOSM code, only change the target of the already existing button to call external webpage.

Changed 9 months ago by Klumbumbus

Attachment: buttonhistoryviewer.png added

comment:8 Changed 9 months ago by Klumbumbus

You mean that this button would get a dropdown list to choose another target then the deafult? That sounds fine.

comment:9 Changed 9 months ago by Don-vip

The button opens the changeset manager. It would be better to add a drop down arrow next to the link on its right, which proposes the two other suggested websites.

comment:10 Changed 9 months ago by stoecker

Hmm, ah, should have clicked the button then before typing :-)

comment:11 Changed 8 months ago by Don-vip

Milestone: 17.0417.05

comment:12 Changed 7 months ago by Don-vip

Ticket #14739 has been marked as a duplicate of this ticket.

comment:13 Changed 7 months ago by Don-vip

Milestone: 17.0517.06

comment:14 Changed 6 months ago by Don-vip

Milestone: 17.0617.07

comment:15 Changed 5 months ago by Don-vip

Milestone: 17.0717.08

Changed 5 months ago by simon04

Attachment: 14578.patch added

Changed 5 months ago by simon04

comment:16 in reply to:  8 Changed 5 months ago by simon04

Summary: Use osmhv as external history viewer[Patch] Use osmhv as external history viewer


comment:17 Changed 5 months ago by Don-vip

Nice! It would be great also to be able to access these links from changeset manager. I'm not sure however where this should fit in the HMI.

comment:18 Changed 5 months ago by Klumbumbus

Can we use labels instead of blank URLs, e.g. Open in achavi and icons if available?

comment:19 Changed 5 months ago by Klumbumbus

It seems achavi and osmhv don't have logos. For achavi we could maybe use the left part of the overpass-api logo

According to osmwiki:Achavi achavi doesn't work for changesets before september 2012. The achavi link in JOSM should be greyed out for older changesets.

comment:20 in reply to:  19 Changed 5 months ago by Don-vip

Replying to Klumbumbus:

According to osmwiki:Achavi achavi doesn't work for changesets before september 2012. The achavi link in JOSM should be greyed out for older changesets.

The reason why:

Limitation : The earliest possible date to return a result is 2012-09-12 06:55:00 UTC (1347432900 in epoch seconds).

It corresponds to the first change included in the first ODbL compliant planet file, which was created on 2012-09-14. If your query asks for an object in a state prior to what this planet file contains, Overpass API will return the version contained in the first ODbL compliant planet.

comment:21 Changed 4 months ago by Don-vip

Milestone: 17.0817.09

comment:22 Changed 3 months ago by Don-vip

@Simon: are you still working on it? It would be a great enhancement for this month.

comment:23 Changed 3 months ago by simon04

Resolution: fixed
Status: newclosed

In 12871/josm:

fix #14578 - Open external history viewers

Popup menu is added to version info of history dialog and changeset manager.

Changed 3 months ago by simon04

Changed 3 months ago by simon04

comment:24 Changed 3 months ago by Don-vip

Nice!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.