Modify

Opened 7 months ago

Closed 6 months ago

#14571 closed defect (fixed)

Error message after updating Mapillary filter

Reported by: anonymous Owned by: floscher
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download from OSM (select area)
  2. Upadte Mapillary filter e.g. click button right box

What is the expected result?

Continues working normaly, no crash.

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 en_GB) Windows 10 64-Bit
Memory Usage: 464 MB / 910 MB (273 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ HouseNumberTaggingTool (33160)
+ ImageWayPoint (33086)
+ ImportImagePlugin (33028)
+ Mapillary (v1.4.2)
+ OpenStreetCam (53)
+ apache-commons (32994)
+ apache-http (32699)
+ ejml (32680)
+ geotools (33042)
+ imagery-xml-bounds (33004)
+ imagery_offset_db (33004)
+ imageryadjust (33004)
+ jts (32699)
+ log4j (32699)
+ photo_geotagging (33088)
+ photoadjust (33088)
+ scoutsigns (95)

Last errors/warnings:
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-6-thread-1 (138)
java.lang.NullPointerException
	at org.glassfish.json.JsonObjectBuilderImpl$JsonObjectImpl.getString(JsonObjectBuilderImpl.java:199)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryImageInfoDownloadThread.lambda$run$1(MapillaryImageInfoDownloadThread.java:62)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:184)
	at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175)
	at java.util.concurrent.ConcurrentHashMap$KeySpliterator.forEachRemaining(ConcurrentHashMap.java:3527)
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
	at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryImageInfoDownloadThread.run(MapillaryImageInfoDownloadThread.java:61)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (2)

comment:1 Changed 7 months ago by Don-vip

Component: CorePlugin mapillary
Owner: changed from team to floscher

comment:2 Changed 6 months ago by floscher

Resolution: fixed
Status: newclosed

I'll close this now, because the whole JSON decoding process has been reworked for v1.5.0+.

So the part of the code, which triggered the issue is no longer present.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain floscher.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.