Modify

Opened 5 months ago

Closed 5 months ago

#14538 closed defect (duplicate)

<Shift>-<J> Creates Multi-Polygon Rather than 'Join Overlapping Areas'

Reported by: alexkemp Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Update system then launch JOSM + Bing imagery
  2. Press <B> and create house; press <Shift>-<T> and split in two (semi-detached)
  3. Whilst semi is selected; press <B> and create 'house' for rear extension of semi; press <Shift>-<T> and also split extension in two and line up with front houses
  4. Select front & rear of semi-detached, then press <Shift>-<J> to join front + back of semi-detached

What is the expected result?

Full outline of semi-detached house

What happens instead?

Overlap gets made into a multipolygon instead

Please provide any additional information below. Attach a screenshot if possible.

I'm not sure exactly when the behaviour changed. However, JOSM-stable (11639) is fine, and I've attached screen-shots of the create process through to completion to try to help understanding.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-03-19 02:26:34 +0100 (Sun, 19 Mar 2017)
Build-Date:2017-03-19 02:34:23
Revision:11746
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11746 en_GB) Linux Debian GNU/Linux 8.7 (jessie)
Memory Usage: 687 MB / 1636 MB (149 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-1~bpo8+1-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Java package: openjdk-8-jre:amd64-8u121-b13-1~bpo8+1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.5-1
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (33182)
+ Mapillary (v1.4.2)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ continuosDownload (53)
+ terracer (33088)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (4)

Workspace 1_001.png (397.1 KB) - added by alexkemp 5 months ago.
Workspace showing the errant multi-polygon creation (JOSM-latest)
semi-detached_create_front.png (373.2 KB) - added by alexkemp 5 months ago.
Workspace during creation of semi-detached house, front-part (JOSM-tested)
semi-detached_create_back.png (381.8 KB) - added by alexkemp 5 months ago.
Workspace during creation of semi-detached house, back-part (JOSM-tested)
semi-detached_create_success.png (387.9 KB) - added by alexkemp 5 months ago.
Workspace during successful creation of semi-detached houseusing shift-J (JOSM-tested)

Download all attachments as: .zip

Change History (5)

Changed 5 months ago by alexkemp

Attachment: Workspace 1_001.png added

Workspace showing the errant multi-polygon creation (JOSM-latest)

Changed 5 months ago by alexkemp

Workspace during creation of semi-detached house, front-part (JOSM-tested)

Changed 5 months ago by alexkemp

Workspace during creation of semi-detached house, back-part (JOSM-tested)

Changed 5 months ago by alexkemp

Workspace during successful creation of semi-detached houseusing shift-J (JOSM-tested)

comment:1 Changed 5 months ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14528.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.