Modify

Opened 7 months ago

Closed 2 months ago

Last modified 2 months ago

#14524 closed defect (fixed)

Loading saved session - Mapbox tiles won't load.

Reported by: Glassman Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report session mapbox Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Save a session with mapbox tile and others loaded
  2. Exit JOSM
  3. Reopen JOSM
  4. Open saved session

What is the expected result?

Expected to be back in the same configuration as when the session was saved.

What happens instead?

Everything loads properly except for the Mapbox image layer. It returns a tile message "increase tiles zoom level (change resolution) to see more detail" Changing resolution only brings up the hour glass symbox tile. See attached screen shot.

Please provide any additional information below. Attach a screenshot if possible.

screenshot of josm edit area showing the hourglass tile from the mapbox layer

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-03-14 19:27:54 +0100 (Tue, 14 Mar 2017)
Build-Date:2017-03-15 02:34:28
Revision:11732
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11732 en) Linux Fedora release 25 (Twenty Five)
Memory Usage: 1399 MB / 7150 MB (657 MB allocated, but free)
Java version: 1.8.0_121-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x1080, :0.1 1920x1080
Maximum Screen Size: 3840x1080
Java package: java-1.8.0-openjdk:x86_64-1.8.0.121
VM arguments: [-agentpath:/usr/lib/abrt-java-connector/libabrt-java-connector.so=abrt=on]
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (33028)
+ ImproveOsm (97)
+ ImproveWay (12)
+ InfoMode (33004)
+ Mapillary (v1.4.2)
+ OpeningHoursEditor (33185)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ ext_tools (33004)
+ geochat (33088)
+ geotools (33042)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ opendata (33156)
+ pbf (33165)
+ pdfimport (33004)
+ public_transport (33166)
+ reverter (33088)
+ routes (33126)
+ splinex (33160)
+ tofix (277)
+ undelete (32699)
+ utilsplugin2 (33182)
+ wikipedia (33098)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://github.com/igitov/forest-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
- ${HOME}/josmfile
+ ${HOME}/elemstyles.mapcss

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginListParseException: Failed to create plugin information from manifest for plugin 'mbtiles.jar'. Cause: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin mbtiles. Cause: java.io.IOException: invalid manifest format
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.tofix.TofixDialog$3@7efaf10b
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.tofix.TofixDialog$4@5dbaeba2
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.tofix.TofixDialog$5@49bbba14

Attachments (2)

mapbox_error.png (456.6 KB) - added by Glassman 7 months ago.
screenshot of josm edit area showing the hourglass tile from the mapbox layer
farmland.joz (1.7 MB) - added by Glassman 7 months ago.
joz file

Change History (14)

Changed 7 months ago by Glassman

Attachment: mapbox_error.png added

screenshot of josm edit area showing the hourglass tile from the mapbox layer

comment:1 Changed 7 months ago by Klumbumbus

Component: CoreCore imagery

comment:2 Changed 7 months ago by Don-vip

Description: modified (diff)

comment:3 Changed 7 months ago by Don-vip

Keywords: session mapbox added
Owner: changed from team to Glassman
Status: newneedinfo

Works for me. Can you please attach your .joz file?

Changed 7 months ago by Glassman

Attachment: farmland.joz added

joz file

comment:4 Changed 7 months ago by Glassman

Here is my .joz file

comment:5 Changed 4 months ago by Don-vip

Owner: changed from Glassman to team
Status: needinfonew

comment:6 Changed 4 months ago by bastiK

The problem is, that in the layer right click menu, the option "Auto load tiles" and "Auto zoom" are ticked off.

First of all, with "Auto load tiles" off, it is not supposed to load anything. Even if this option was ticked, there is still a JOSM bug with the second option:

When "Auto zoom" is off, the current (locked) zoom level becomes relevant, but this number is not saved in the session file. In the reloaded session, the locked zoom level seems to be 0, which is useless.

comment:7 Changed 2 months ago by bastiK

In 12600/josm:

see #14524 - use inteface SessionAwareReadApply

comment:8 Changed 2 months ago by bastiK

In 12603/josm:

see #14524 - make AbstractTileSourceLayer#currentZoomLevel private and use getter instead of public access

comment:9 Changed 2 months ago by bastiK

Resolution: fixed
Status: newclosed

In 12604/josm:

fixed #14524 - save imagery layer zoom level to session (if needed)

comment:10 Changed 2 months ago by Don-vip

Concerning instanceOfThen, worth reading: http://openjdk.java.net/jeps/305

I hope to see this in Java 10 :)

comment:11 Changed 2 months ago by bastiK

It's fun to toy around with lambdas and streams, not sure it improves the readability that much, though.

comment:12 Changed 2 months ago by Don-vip

In 12618/josm:

see #14524 - suppress java warning

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.