Modify

Opened 6 weeks ago

Closed 6 weeks ago

#14521 closed defect (duplicate)

Unexpected exception at startup.

Reported by: mapper377 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc: javabug

Description

What steps will reproduce the problem?

  1. Click on the josm-tested-11369.jar icon to invoke JOSM. Mac OS X 10.10.5. Java version 1.8.0_121.
  2. I cannot reproduce the bug.

What is the expected result?

JOSM should start normally, which did not happen on this invocation.

What happens instead?

A window appeared titled "You have encountered a bug in JOSM". It offered a choice to report the bug, and this is the report.
I cannot report the behavior after invoking JOSM because I stepped away from the computer while the statup process was running. I found the "You have encountered a bug in JOSM" window" only after i returned a few minutes later.

Please provide any additional information below. Attach a screenshot if possible.

I then quit JOSM and invoked it again. JOSM then started normally.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 en) Mac OS X 10.10.5
Memory Usage: 452 MB / 2276 MB (223 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69522572 1920x1200
Maximum Screen Size: 1920x1200

Plugins:
+ Mapillary (v1.4.0)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ editgpx (33004)
+ utilsplugin2 (33124)

Last errors/warnings:
- E: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at javax.swing.BoxLayout.preferredLayoutSize(BoxLayout.java:302)
	at javax.swing.JToolBar$DefaultToolBarLayout.preferredLayoutSize(JToolBar.java:771)
	at java.awt.Container.preferredSize(Container.java:1796)
	at java.awt.Container.getPreferredSize(Container.java:1780)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1664)
	at java.awt.BorderLayout.layoutContainer(BorderLayout.java:815)
	at java.awt.Container.layout(Container.java:1510)
	at java.awt.Container.doLayout(Container.java:1499)
	at java.awt.Container.validateTree(Container.java:1695)
	at java.awt.Container.validateTree(Container.java:1704)
	at java.awt.Container.validateTree(Container.java:1704)
	at java.awt.Container.validateTree(Container.java:1704)
	at java.awt.Container.validate(Container.java:1630)
	at java.awt.Window.dispatchEventImpl(Window.java:2744)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (3)

comment:1 Changed 6 weeks ago by stoecker

Cc: javabug added
Resolution: othersoftware
Status: newclosed

If it happens again or is reproducible please reopen/report again. The error seems to be a plain Java issue. It may be caused by an error in JOSM, but there is not much we can do with above details.

comment:2 Changed 6 weeks ago by Don-vip

Resolution: othersoftware
Status: closedreopened

comment:3 Changed 6 weeks ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #13100.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.