Modify

Opened 6 weeks ago

Closed 5 weeks ago

#14519 closed defect (duplicate)

Exception when reverting changeset 45592770

Reported by: anonymous Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM
  2. Revert Changeset -> enter 45592770 -> OK

What is the expected result?

Changeset downloads/reverts

What happens instead?

Exception raised

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-03-13 20:29:33 +0100 (Mon, 13 Mar 2017)
Build-Date:2017-03-14 02:32:13
Revision:11731
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11731 en_AU) Linux Ubuntu 16.04.1 LTS
Memory Usage: 666 MB / 1755 MB (476 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-0ubuntu1.16.04.2-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1024x768, :0.1 1280x720
Maximum Screen Size: 1280x768
Java package: openjdk-8-jre:amd64-8u121-b13-0ubuntu1.16.04.2
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (1010)
+ FixAddresses (33182)
+ HouseNumberTaggingTool (33160)
+ ImproveOsm (97)
+ Mapillary (v1.4.2)
+ OpeningHoursEditor (33185)
+ ShapeTools (1220)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33042)
+ jts (32699)
+ log4j (32699)
+ opendata (33156)
+ reverter (33088)
+ terracer (33088)
+ utilsplugin2 (33182)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginListParseException: Failed to create plug-in information from manifest for plug-in 'mbtiles.jar'. Cause: org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in mbtiles. Cause: java.io.IOException: invalid manifest format
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401
- W: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401
- E: org.openstreetmap.josm.plugins.PluginListParseException: Failed to create plug-in information from manifest for plug-in 'mbtiles.jar'. Cause: org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in mbtiles. Cause: java.io.IOException: invalid manifest format
- E: org.openstreetmap.josm.plugins.PluginListParseException: Failed to create plug-in information from manifest for plug-in 'mbtiles.jar'. Cause: org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in mbtiles. Cause: java.io.IOException: invalid manifest format
- E: java.util.concurrent.ExecutionException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401. Cause: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401
- E: java.util.concurrent.ExecutionException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401. Cause: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401
- E: java.util.concurrent.ExecutionException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401. Cause: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401
- E: java.util.concurrent.ExecutionException: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401. Cause: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401
- E: Handled by bug report queue: java.lang.IllegalStateException: Missing merge target of type node with id 2,496,134,607


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalStateException: Missing merge target of type node with id 2,496,134,607
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:62)
	at reverter.DataSetCommandMerger.mergeNode(DataSetCommandMerger.java:82)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:173)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:46)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:350)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:112)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (2)

comment:1 Changed 6 weeks ago by Klumbumbus

Component: CorePlugin reverter
Owner: changed from team to Upliner

comment:2 Changed 5 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13981.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.