Modify

Opened 4 months ago

Closed 4 months ago

#14517 closed defect (duplicate)

Complete Program Freeze for Unknown Reason #2

Reported by: alexkemp Owned by: alexkemp
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report linux atk Cc:

Description

What steps will reproduce the problem?

  1. Update system, JOSM + Plugins (latter unchanged)
  2. Use JOSM usefully + uplift some changes
  3. Complete JOSM freeze whilst "moving" up the road (no obvious thing to indicate what may have caused it)
  4. Details below are after console kill + restart

What is the expected result?

Not a freeze

What happens instead?

A freeze

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-03-13 20:29:33 +0100 (Mon, 13 Mar 2017)
Build-Date:2017-03-14 02:32:13
Revision:11731
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11731 en_GB) Linux Debian GNU/Linux 8.7 (jessie)
Memory Usage: 769 MB / 1636 MB (570 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-1~bpo8+1-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Java package: openjdk-8-jre:amd64-8u121-b13-1~bpo8+1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.5-1
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (33182)
+ Mapillary (v1.4.2)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ continuosDownload (53)
+ terracer (33088)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (2)

Workspace 1_001.png (1.0 MB) - added by alexkemp 4 months ago.
Approx location at which program froze whilst moving from St Mary's Rest Garden to St Anns Well Road just beyond Lamartine Street
jstack_trace.txt (55.8 KB) - added by Don-vip 4 months ago.

Download all attachments as: .zip

Change History (7)

Changed 4 months ago by alexkemp

Attachment: Workspace 1_001.png added

Approx location at which program froze whilst moving from St Mary's Rest Garden to St Anns Well Road just beyond Lamartine Street

comment:1 Changed 4 months ago by Don-vip

Keywords: linux atk added
Owner: changed from team to alexkemp
Status: newneedinfo

I see you have an old version of libatk-wrapper-java.
These old versions completely break Java applications.

Can you please try to update it, or disable it according to https://josm.openstreetmap.de/ticket/12022#comment:40 ?

comment:2 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #12022.
If the method to disable ATK wrapper has changed since my last comment, can you please share it in #12022 comments?

comment:3 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: closedreopened

Changed 4 months ago by Don-vip

Attachment: jstack_trace.txt added

comment:4 Changed 4 months ago by Don-vip

From 12022#comment:72:

It has reoccurred once again with JOSM-stable. A stack-trace using jps then jstack 8820 > ./jstack_trace.txt attached. No mention of ATK appears anywhere within the trace (because ATK-Wrapper is switched OFF in Debian) (cat jstack_trace.txt | fgrep -i atk).

comment:5 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #13283.
I didn't it was also in #13283 let's keep this one only.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain alexkemp.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.