Modify

Opened 11 days ago

Closed 11 days ago

#14515 closed defect (duplicate)

IllegalStateException: Missing merge target

Reported by: adb422006@… Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Created docks and many other ways and nodes
  2. Deleted docks
  3. Asked for changeset to be reverted
  4. Crash

What is the expected result?

Reverting of changeset

What happens instead?

Crash

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 en_GB) Windows 8.1 64-Bit
Memory Usage: 190 MB / 989 MB (104 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Dataset consistency test:
[WARN - NO NODES] Way {Way id=6515314 version=3 VT nodes=[{Node id=58719780 version=2 V lat=56.026535,lon=47.1718053}]} has only one node


Plugins:
+ FastDraw (33004)
+ PicLayer (33148)
+ continuosDownload (53)
+ measurement (33088)
+ reverter (33088)
+ turnrestrictions (33088)

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalStateException: Missing merge target of type node with id 61,151,958

OSM API: http://opengeofiction.net/api


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalStateException: Missing merge target of type node with id 61,151,958
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:62)
	at reverter.DataSetCommandMerger.mergeNode(DataSetCommandMerger.java:82)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:173)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:46)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:350)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:112)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 11 days ago by Don-vip

Component: CorePlugin reverter
Owner: changed from team to Upliner

comment:2 Changed 11 days ago by Don-vip

Summary: CrashIllegalStateException: Missing merge target

comment:3 Changed 11 days ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13981.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.