Modify

Opened 4 months ago

Last modified 3 months ago

#14426 reopened enhancement

"what changed but not yet saved" view

Reported by: nyurik Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

It would be highly useful to have an easy way to view what has changed but hasn't been saved. Something similar to the "history" view, but without downloading the entire history of an object.

Attachments (0)

Change History (3)

comment:1 Changed 4 months ago by Klumbumbus

There is a mappaint style: Styles/Modified

Last edited 4 months ago by Klumbumbus (previous) (diff)

comment:2 Changed 4 months ago by stoecker

Resolution: worksforme
Status: newclosed

There is a also a search function for modified objects.

comment:3 Changed 3 months ago by nyurik

Resolution: worksforme
Status: closedreopened

Clarification: At the moment, there is no easy way to view just what has been modified, rather than seeing the whole history - tags only. For example, if I change a tag on an object, for me to see that change I have to go to the object and click history. Then it shows me the difference between the OSM version and my changes as a side by side diff. The problem is when there are multiple objects changed, I have to go one by one through all of the objects, click history on each (which downloads the whole history, instead of just showing the local changes).

Even better, the "save changes" screen should show a table of all tag changes, combined (e.g. github's diff view, with each object as a section), or alternative view with the same changes combined into one line. E.g. object 1,2,3 tagX valA->valB, object 4,5 tagY valC->valD.

Basically, when uploading, there is no easy way to see what has changed, at least in tags. In Wikipedia, when I change an article, I can click "see diff with existing article", which shows my changes before i save. I think this would be a great addition to JOSM, and will help prevent accidental mistakes.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from team to the specified user. Next status will be 'new'.
Next status will be 'needinfo'.The owner will change to nyurik
as duplicate The resolution will be set to duplicate. Next status will be 'closed'.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.