Modify

Opened 10 months ago

Closed 10 months ago

Last modified 9 months ago

#14323 closed defect (fixed)

Validator warning on odd number of lanes (>= 3) in roundabout without oneway attribute

Reported by: FvGordon Owned by: team
Priority: normal Milestone: 17.02
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open way 214367243 in JOSM (a part of a roundabout with lanes=3 and junction roundabout, but no oneway attribute)
  2. Run the validator

What is the expected result?

No warning

What happens instead?

Validator gives a warning: Way with odd count of lanes with no lanes:forward and lanes:backward or oneway)

Please provide any additional information below. Attach a screenshot if possible.

Roundabouts should be treated as oneways here.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-02 01:22:52 +0100 (Thu, 02 Feb 2017)
Build-Date:2017-02-02 02:33:28
Revision:11526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11526 de) Windows 7 64-Bit
Memory Usage: 299 MB / 966 MB (165 MB allocated, but free)
Java version: 1.8.0_31-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050
Dataset consistency test: No problems found

Plugins:
+ imageryadjust (33004)
+ jogl (1.0.46)
+ kendzi3d (1.0.194)
+ kendzi3d-resources (0.0.1)
+ log4j (32699)
+ measurement (33088)
+ reverter (33088)
+ turnlanes (33088)
+ turnrestrictions (33088)
+ undelete (32699)
+ utilsplugin2 (33124)

Last errors/warnings:
- W: Erweiterungen aktualisieren - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte überprüfen Sie Ihre Internetverbindung.. Ursache: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte überprüfen Sie Ihre Internetverbindung.. Ursache: java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (3)

comment:1 Changed 10 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 11529/josm:

fix #14323, see #14125 - don't warn about odd number of lanes without lanes:forward|backward in roundabouts

comment:2 Changed 10 months ago by Klumbumbus

Milestone: 17.02

comment:3 Changed 9 months ago by Don-vip

Ticket #14396 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.