Modify

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#14264 closed defect (fixed)

Wrongly displaying aerialway=chair_lift + oneway=no with direction arrows

Reported by: naoliv Owned by: team
Priority: normal Milestone: 17.01
Component: Core mappaint Version:
Keywords: Cc:

Description

Draw a way with aerialway=chair_lift + oneway=no and see how JOSM renders it with direction arrows indicating that it's oneway.

https://wiki.openstreetmap.org/wiki/Key:aerialway says that Any two-way chairlifts should be tagged oneway=no

JOSM:

Build-Date:2017-01-18 10:04:40
Revision:11481
Is-Local-Build:true

Identification: JOSM/1.5 (11481 SVN pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 587 MB / 10206 MB (176 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-3-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u111-b14-3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Attachments (0)

Change History (15)

comment:1 Changed 8 months ago by naoliv

BTW, while at it, if we validate a way with aerialway=chair_lift + oneway=no JOSM also issues a wrong missing tag - oneway without highway or railway

comment:2 Changed 8 months ago by Klumbumbus

Milestone: 17.01

comment:3 Changed 8 months ago by Klumbumbus

It's strange, that a chair_lift should imply oneway=yes. Usually you can drive (or ride?) on a chair lift also downwards.

comment:4 Changed 8 months ago by naoliv

I guess they say about oneway=no in cases like this, where only one way (line) is used to represent both directions?
https://wiki.openstreetmap.org/w/images/thumb/2/27/Silver_Queen_Chair%2C_CBMR.jpg/800px-Silver_Queen_Chair%2C_CBMR.jpg

ie, we don't draw two lines to represent the sides that ascend and descend.

comment:5 in reply to:  4 Changed 8 months ago by Klumbumbus

Replying to naoliv:

I guess they say about oneway=no in cases like this, where only one way (line) is used to represent both directions?

I don't understand this sentence.

comment:6 Changed 8 months ago by naoliv

Instead using two ways to represent the above picture, like this:
https://i.imgur.com/CXCPyTQ.png

We use only one way with oneway=no:
https://i.imgur.com/KsJgOEW.png

Last edited 8 months ago by naoliv (previous) (diff)

comment:7 Changed 8 months ago by Klumbumbus

Yes we map aerialways with a single line. However at nearly all chairlifts you can ride downwards too. So oneway=no should be implied. However the wiki says "This implies oneway=yes (drawn upward). Any two-way chairlifts should be tagged oneway=no." It make no sense to put oneway=no on 99% of all chair lifts.

Usually nobody used the chair lift downwards in winter, but you could ;)

comment:8 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 11499/josm:

fix #14264 - displaying oneway direction arrows of aerialways according to wiki, don't display them if oneway=no is set

comment:11 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 11501/josm:

fix #14264 - fix unit test

comment:12 Changed 8 months ago by Don-vip

In 11503/josm:

see #14264 - checkstyle

comment:13 in reply to:  1 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: closedreopened

Replying to naoliv:

BTW, while at it, if we validate a way with aerialway=chair_lift + oneway=no JOSM also issues a wrong missing tag - oneway without highway or railway

forgot that part

comment:14 Changed 8 months ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 11513/josm:

fix #14264 - don't warn about aerialway oneway combination

comment:15 Changed 8 months ago by Klumbumbus

Ticket #14314 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.