Modify

Opened 2 months ago

Closed 2 months ago

#14244 closed defect (fixed)

Expand combobox in preferences

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.01
Component: Core Version: latest
Keywords: template_report combobox width Cc: kidelo

Description

What steps will reproduce the problem?

  1. Open preferences
  2. Change velocity
  3. Not all text can be seen in the combobox.

What is the expected result?

All text can be seen in the combobox.

What happens instead?

Not all text can be seen in the combobox.

Please provide any additional information below. Attach a screenshot if possible.



URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-14 21:10:48 +0100 (Sat, 14 Jan 2017)
Build-Date:2017-01-15 02:35:18
Revision:11463
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11463 da) Windows XP 32-Bit
Memory Usage: 157 MB / 247 MB (51 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1152x864
Maximum Screen Size: 1152x864
VM arguments: [-Duser.home=%UserProfile%]

Plugins:
+ BuildingGeneralization (1010)
+ DxfImport (1008)
+ Mapillary (v1.3.2)
+ PicLayer (33088)
+ ShapeTools (1220)
+ apache-commons (32994)
+ apache-http (32699)
+ areaselector (1478814827)
+ continuosDownload (53)
+ junctionchecking (33088)
+ log4j (32699)
+ pdfimport (33004)
+ pt_assistant (33108)
+ reverter (33088)
+ tageditor (33021)
+ todo (30000)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ utilsplugin2 (33088)
+ wikipedia (33098)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'

Attachments (3)

Expand combobox en.PNG (67.8 KB) - added by anonymous 2 months ago.
Expand combobox da.PNG (5.6 KB) - added by anonymous 2 months ago.
Expand combobox 3.PNG (7.1 KB) - added by anonymous 2 months ago.

Download all attachments as: .zip

Change History (7)

Changed 2 months ago by anonymous

Attachment: Expand combobox en.PNG added

Changed 2 months ago by anonymous

Attachment: Expand combobox da.PNG added

comment:1 Changed 2 months ago by anonymous

Also expand combobox for heat map.

Changed 2 months ago by anonymous

Attachment: Expand combobox 3.PNG added

comment:2 Changed 2 months ago by Don-vip

Cc: kidelo added
Keywords: combobox width added
Milestone: 17.01

comment:3 Changed 2 months ago by kidelo

I think we should adjust the width of the combobox in a manner like the detection of the maximum height, see:

25	/**
26	 * Class overriding each {@link JComboBox} in JOSM to control consistently the number of displayed items at once.<br/>
27	 * This is needed because of the default Java behaviour that may display the top-down list off the screen (see #7917).
28	 *
29	 * @since 5429
30	 */
31	public class JosmComboBox extends JComboBox {

...

117	     * Finds the prototype display value to use among the given possible candidates.
118	     * @param possibleValues The possible candidates that will be iterated.
119	     * @return The value that needs the largest display height on screen.
120	     * @since 5558
121	     */
122	    protected Object findPrototypeDisplayValue(Collection<?> possibleValues)

Then we have a common solution for all the languages.

comment:4 Changed 2 months ago by bastiK

Resolution: fixed
Status: newclosed

In 11474/josm:

fixed #14244 - Expand combobox in preferences; add translation context

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.