Modify

Opened 4 months ago

Closed 12 days ago

Last modified 12 days ago

#14195 closed defect (irreproducible)

Combine ways: Falsely coloured first tag with only conflict in roles

Reported by: skyper Owned by: skyper
Priority: minor Milestone:
Component: Core Version:
Keywords: template_report combine conflict Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. combine two ways with all tags in common and only differences in membership

What is the expected result?

No colouring of any tag in the tag/membership conflict dialog

What happens instead?

The first tag is in yellow without any conflict

Please provide any additional information below. Attach a screenshot if possible.

See test file

screenshot

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-02 22:50:04 +0100 (Mon, 02 Jan 2017)
Build-Date:2017-01-03 02:35:14
Revision:11428
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11428 de) Linux Debian GNU/Linux 8.6 (jessie)
Memory Usage: 371 MB / 882 MB (130 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2~bpo8+1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-8-jre:amd64-8u111-b14-2~bpo8+1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.4-3
Dataset consistency test: No problems found

Last errors/warnings:
- W: JOSM erwartet das Objekt [Linie -38587] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception
- W: JOSM erwartet das Objekt [Linie -38586] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception
- W: JOSM erwartet das Objekt [Linie -38590] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception
- W: JOSM erwartet das Objekt [Linie -38589] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception
- W: JOSM erwartet das Objekt [Linie -38588] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception

Do not ask about the Exception and the Warning, Did not notice but did purge objects this session.

Attachments (3)

josm_14195_screenshot.png (64.8 KB) - added by skyper 4 months ago.
screenshot
josm_14195_test.osm (6.3 KB) - added by skyper 4 months ago.
example file
14195_worksforme.png (16.5 KB) - added by Don-vip 8 weeks ago.

Download all attachments as: .zip

Change History (8)

Changed 4 months ago by skyper

Attachment: josm_14195_screenshot.png added

screenshot

Changed 4 months ago by skyper

Attachment: josm_14195_test.osm added

example file

comment:1 Changed 4 months ago by skyper

Description: modified (diff)

comment:2 Changed 4 months ago by skyper

#13676 seems to be similar but with merging nodes

Changed 8 weeks ago by Don-vip

Attachment: 14195_worksforme.png added

comment:3 Changed 8 weeks ago by Don-vip

Owner: changed from team to skyper
Status: newneedinfo

Works for me:


Build-Date:2017-03-05 01:51:37
Revision:11683
Is-Local-Build:true

Identification: JOSM/1.5 (11683 SVN en) Windows 10 64-Bit
Memory Usage: 531 MB / 3634 MB (330 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 1280x1024
Maximum Screen Size: 1920x1080
VM arguments: [-Dfile.encoding=UTF-8]

Do you still have the problem?

comment:4 in reply to:  3 Changed 12 days ago by skyper

Resolution: fixed
Status: needinfoclosed

Replying to Don-vip:

Do you still have the problem?

No seems to be fixed.

comment:5 Changed 12 days ago by Don-vip

Resolution: fixedirreproducible

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain skyper.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.