Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#14185 closed defect (fixed)

Crash during the startup loading

Reported by: meihou Owned by: team
Priority: critical Milestone: 17.01
Component: Core Version: tested
Keywords: template_report Cc:

Description

Crash during the startup loading.
Just after the imagery setting loading.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-12-31 17:39:03 +0100 (Sat, 31 Dec 2016)
Build-Date:2016-12-31 17:38:24
Revision:11425
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11425 fr) Windows 10 64-Bit
Memory Usage: 377 MB / 910 MB (184 MB allocated, but free)
Java version: 1.8.0_60-b27, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1600x900
Maximum Screen Size: 1600x900

Plugins:
+ PicLayer
+ apache-commons
+ cadastre-fr
+ ejml
+ geotools
+ jts
+ opendata
+ turnrestrictions
+ utilsplugin2

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.. Cause : java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.. Cause : org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.
	at org.openstreetmap.josm.Main.initialize(Main.java:563)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:336)
Caused by: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.Main.initialize(Main.java:555)
	... 1 more
Caused by: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.
	at org.openstreetmap.josm.actions.JoinAreasAction.findBoundaryPolygons(JoinAreasAction.java:1170)
	at org.openstreetmap.josm.actions.JoinAreasAction.joinAreas(JoinAreasAction.java:647)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.computeOptimizedBoundaries(RightAndLefthandTraffic.java:112)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.initialize(RightAndLefthandTraffic.java:67)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:602)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:586)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (5)

comment:1 Changed 7 months ago by Don-vip

Milestone: 17.01

comment:2 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 11427/josm:

fix #14185 - see #10511 - robustness when joining algorithm fails during boundaries database initialization

comment:3 Changed 7 months ago by skyper

Ticket #14188 has been marked as a duplicate of this ticket.

comment:4 Changed 7 months ago by skyper

Ticket #14189 has been marked as a duplicate of this ticket.

comment:5 Changed 7 months ago by Don-vip

Priority: normalcritical

It seems quite frequent, a new tested release is being published as hotfix: r11427

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.