Modify

Opened 12 months ago

Closed 4 weeks ago

#14101 closed defect (fixed)

Keystrokes in filters get captured as shortcuts

Reported by: DevonF Owned by: team
Priority: normal Milestone: 17.11
Component: Core Version:
Keywords: template_report Cc: Stereo

Description

In the filter window, after adding an entry, edit the text directly in text box and anything typed there also gets captured and read as a shortcut. For example typing in addr:city=* the draw node, reverse way, and zoom in are all triggered. Not to mention after pressing a conflicting key like 'a' or 's', the textbox loses focus and need to re-select it.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-06 20:18:38 +0100 (Sun, 06 Nov 2016)
Build-Date:2016-11-06 21:45:03
Revision:11223
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11223 en) Linux Ubuntu 16.10
Memory Usage: 571 MB / 839 MB (98 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2ubuntu0.16.10.2-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1366x768, :0.1 1280x1024
Maximum Screen Size: 1366x1024
Java package: openjdk-8-jre:amd64-8u111-b14-2ubuntu0.16.10.2
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ public_transport (33088)

Last errors/warnings:
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- E: org.openstreetmap.josm.actions.search.SearchCompiler$ParseError: Unexpected token: <equals>
- E: org.openstreetmap.josm.actions.search.SearchCompiler$ParseError: Unexpected token: <equals>
- E: org.openstreetmap.josm.actions.search.SearchCompiler$ParseError: Unexpected token: <equals>
- E: org.openstreetmap.josm.actions.search.SearchCompiler$ParseError: Unexpected token: <equals>

Attachments (0)

Change History (5)

comment:1 Changed 12 months ago by Klumbumbus

similar to #14019

comment:2 Changed 12 months ago by Don-vip

Ticket #14019 has been marked as a duplicate of this ticket.

comment:3 Changed 12 months ago by Stereo

Cc: Stereo added

comment:4 Changed 4 weeks ago by Don-vip

Milestone: 17.11

comment:5 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13137/josm:

fix #14101 - Keystrokes in filters get captured as shortcuts

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.