Modify

Opened 14 months ago

Closed 3 weeks ago

#14013 closed defect (fixed)

Buttons not working

Reported by: battarsa Owned by: OliverW
Priority: normal Milestone:
Component: Plugin fixaddresses Version:
Keywords: fixaddresses buttons Cc: javiersanp, dcapillae

Description

In the address correction windows, the editing buttons are always grayed.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-06 20:18:38 +0100 (Sun, 06 Nov 2016)
Build-Date:2016-11-06 21:45:03
Revision:11223
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11223 it) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 1188 MB / 3332 MB (76 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-3-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u111-b14-3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-11
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ FastDraw (32938)
+ FixAddresses (32796)
+ OpeningHoursEditor (32699)
+ apache-commons (32699)
+ apache-http (32699)
+ imagery_offset_db (32796)
+ jna (32699)
+ native_password_manager (32699)
+ reverter (32796)
+ scripting (30761)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Oggetti eliminati o spostati - <html>C'è 1 oggetto nel proprio insieme di dati locale che potrebbe essere eliminato sul server.<br>Se si prova successivamente ad eliminarlo o ad aggiornarlo il server probabilmente segnalerà un conflitto.<br>Clicca su <strong>Controllo sul server</strong> per controllare lo stato di questo oggetto sul server.<br>Clicca su <strong>Ignora</strong> per ignorare.</html>
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Versione principale dell'estensione mancante nella estensione jython-standalone-2.5.3

Attachments (1)

fix14013.diff (4.0 KB) - added by javiersanp 3 weeks ago.
Fix to resolve issue #14013

Download all attachments as: .zip

Change History (8)

comment:1 Changed 14 months ago by NonnEmilia

Also for me.

I'm using the same JOSM version (11223), same locale (it) and Ubuntu 16.04 LTS.

comment:2 Changed 14 months ago by anonymous

Also with this fresh configuration:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-06 20:18:38 +0100 (Sun, 06 Nov 2016)
Build-Date:2016-11-06 21:45:03
Revision:11223
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11223 it) Windows 10 64-Bit
Memory Usage: 199 MB / 247 MB (27 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\Downloads\Mappe\josm.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=51034, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (33004)

comment:3 Changed 5 weeks ago by Don-vip

Ticket #15672 has been marked as a duplicate of this ticket.

comment:4 Changed 5 weeks ago by Don-vip

Cc: javiersanp dcapillae added

Changed 3 weeks ago by javiersanp

Attachment: fix14013.diff added

Fix to resolve issue #14013

comment:5 Changed 3 weeks ago by javiersanp

Hello. I have attached a diff that hope will solve the bug.

In plugins/fixAddresses/gui/AddressEditDialog.java, the buttons was created with a new instance of the actions instead of the ones that were saved in the actions array. When a event occurs, it went to the actions of the array not to the dupplicated ones linked to the buttons. I replaced the duplicated calls to AddressAction.getXxxxAction() with the existing instances when creating the buttons. In order to simplify the code, I have removed the spacer resulting in a slight reordering of the buttons in the unresolvedButtons panel.

comment:6 Changed 3 weeks ago by stoecker

Summary: Buttons not working[PATCH] Buttons not working

comment:7 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed
Summary: [PATCH] Buttons not workingButtons not working

Thanks for the patch!

Fixed in [o33963:33964].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.