Modify

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#13985 closed defect (fixed)

Freezes half way through loading geojson

Reported by: simon04 Owned by: simon04
Priority: major Milestone: 16.12
Component: Core Version:
Keywords: regression Cc:

Description

From https://github.com/JOSM/geojson/issues/3:

This plugin isn't working at all for me. After selecting a file it shows a progress bar "Loading json file..." but always stops half way along and freezes up

By freezing up I mean, I can hear my CPU fan going, but nothing's happening. At this point the 'Cancel' button doesn't work, but I can close the dialog box to continue. If I run JSON in a terminal I see this

2016-11-15 23:23:17.046 INFO: Open file: /Users/harrywood/Desktop/restaurants-goswell-rd.geojson (2181 bytes)
2016-11-15 23:23:17.046 INFO: Parsing GeoJSON: /Users/harrywood/Desktop/restaurants-goswell-rd.geojson
It also says I'm using plugin 'geojson' (version 43)

At first I tried this with quite a large geojson file downloaded from the Tasking Manager export feature. Then I tried a much smaller simpler file: https://gist.githubusercontent.com/harry-wood/e96599042264e7f78cbb/raw/9508ff713a254b093d5ce43d1c421847ecb36503/restaurants-goswell-rd.geojson Same problem either way.

Attachments (0)

Change History (3)

comment:1 Changed 8 months ago by simon04

Keywords: regression added

This is a regression of r11033.

comment:2 Changed 8 months ago by simon04

Resolution: fixed
Status: newclosed

In 11261/josm:

fix #13985 - Freezes when creating a layer named "Data Layer "

comment:3 Changed 8 months ago by Don-vip

Milestone: 16.1116.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.