Modify

Opened 10 months ago

Closed 3 months ago

#13855 closed defect (fixed)

ArrayIndexOutOfBoundsException in KeyStore.getCertificateAlias via PlatformHookWindows.setupHttpsCertificate

Reported by: anonymous Owned by: team
Priority: major Milestone: 17.05
Component: Core Version:
Keywords: template_report javabug windows https certificate keystore Cc: erickdeoliveiraleal, boneco

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-10-27 00:37:50 +0200 (Thu, 27 Oct 2016)
Build-Date:2016-10-27 01:34:54
Revision:11179
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11179 pt_BR) Windows 10 64-Bit
Memory Usage: 834 MB / 1801 MB (467 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ FastDraw (32938)
+ ImportImagePlugin (32699)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ apache-commons (32699)
+ ejml (32680)
+ geotools (32813)
+ jts (32699)
+ log4j (32699)
+ michigan_left (32699)
+ opendata (32898)
+ osm-obj-info (1468276210)
+ reverter (32796)
+ scripting (30761)
+ tageditor (33021)
+ todo (30000)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)

Map paint styles:
+ https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
+ C:\Intel\mapcss.css

Validator rules:
- https://raw.githubusercontent.com/OSMBrasil/validador-josm/master/Rules_Brazilian-Specific.validator.mapcss
- https://josm.openstreetmap.de/josmfile?page=Rules/Portuguese-Errors-PT2&zip=1


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.ArrayIndexOutOfBoundsException: 0
	at sun.security.mscapi.KeyStore.engineGetCertificateAlias(KeyStore.java:634)
	at sun.security.mscapi.KeyStore$ROOT.engineGetCertificateAlias(KeyStore.java:61)
	at java.security.KeyStore.getCertificateAlias(Unknown Source)
	at org.openstreetmap.josm.tools.PlatformHookWindows.setupHttpsCertificate(PlatformHookWindows.java:329)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.setupPlatform(RemoteControlHttpsServer.java:303)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.initialize(RemoteControlHttpsServer.java:287)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.<init>(RemoteControlHttpsServer.java:372)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.restartRemoteControlHttpsServer(RemoteControlHttpsServer.java:317)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControl.start(RemoteControl.java:49)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:364)

=== RUNNING THREADS ===
Thread: RemoteControl HTTP Server (39) of main
java.net.DualStackPlainSocketImpl.accept0(Native Method)
java.net.DualStackPlainSocketImpl.socketAccept(Unknown Source)
java.net.AbstractPlainSocketImpl.accept(Unknown Source)
java.net.PlainSocketImpl.accept(Unknown Source)
java.net.ServerSocket.implAccept(Unknown Source)
java.net.ServerSocket.accept(Unknown Source)
org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpServer.run(RemoteControlHttpServer.java:103)

Thread: Image Fetcher 0 (38)
java.lang.Object.wait(Native Method)
sun.awt.image.ImageFetcher.nextImage(Unknown Source)
sun.awt.image.ImageFetcher.fetchloop(Unknown Source)
sun.awt.image.ImageFetcher.run(Unknown Source)

Thread: GT authority factory disposer (33) of main
java.lang.Object.wait(Native Method)
java.util.TimerThread.mainLoop(Unknown Source)
java.util.TimerThread.run(Unknown Source)

Thread: Reference Handler (2) of system
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Unknown Source)
java.lang.ref.Reference.tryHandlePending(Unknown Source)
java.lang.ref.Reference$ReferenceHandler.run(Unknown Source)

Thread: WeakCollectionCleaner (35) of main
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
org.geotools.util.WeakCollectionCleaner.run(WeakCollectionCleaner.java:77)

Thread: TimerQueue (21) of system
java.awt.EventQueue.postEventPrivate(Unknown Source)
java.awt.EventQueue.postEvent(Unknown Source)
java.awt.EventQueue.invokeLater(Unknown Source)
javax.swing.SwingUtilities.invokeLater(Unknown Source)
javax.swing.Timer$1.run(Unknown Source)
javax.swing.Timer$1.run(Unknown Source)
java.security.AccessController.doPrivileged(Native Method)
javax.swing.Timer.post(Unknown Source)
javax.swing.TimerQueue.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: RemoteControl HTTP Server (40) of main
java.net.DualStackPlainSocketImpl.accept0(Native Method)
java.net.DualStackPlainSocketImpl.socketAccept(Unknown Source)
java.net.AbstractPlainSocketImpl.accept(Unknown Source)
java.net.PlainSocketImpl.accept(Unknown Source)
java.net.ServerSocket.implAccept(Unknown Source)
java.net.ServerSocket.accept(Unknown Source)
org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpServer.run(RemoteControlHttpServer.java:103)

Thread: Thread-1 (11) of main
sun.nio.fs.WindowsNativeDispatcher.GetQueuedCompletionStatus0(Native Method)
sun.nio.fs.WindowsNativeDispatcher.GetQueuedCompletionStatus(Unknown Source)
sun.nio.fs.WindowsWatchService$Poller.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: File Watcher (12) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.takeFirst(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.take(Unknown Source)
sun.nio.fs.AbstractWatchService.take(Unknown Source)
org.openstreetmap.josm.io.FileWatcher.processEvents(FileWatcher.java:114)
org.openstreetmap.josm.io.FileWatcher$$Lambda$4/1494279232.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Attach Listener (5) of system

Thread: AWT-Shutdown (14) of system
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Unknown Source)
sun.awt.AWTAutoShutdown.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: AWT-Windows (15) of system
sun.awt.windows.WToolkit.eventLoop(Native Method)
sun.awt.windows.WToolkit.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Java2D Disposer (13) of system
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
sun.java2d.Disposer.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Nashorn AST Serializer (31) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.pollFirst(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.poll(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Nashorn AST Serializer (32) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.pollFirst(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.poll(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Signal Dispatcher (4) of system

Thread: Finalizer (3) of system
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)

Thread: AWT-EventQueue-0 (19) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.awt.EventQueue.getNextEvent(Unknown Source)
java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
java.awt.WaitDispatchSupport$2.run(Unknown Source)
java.awt.WaitDispatchSupport$4.run(Unknown Source)
java.awt.WaitDispatchSupport$4.run(Unknown Source)
java.security.AccessController.doPrivileged(Native Method)
java.awt.WaitDispatchSupport.enter(Unknown Source)
java.awt.Dialog.show(Unknown Source)
java.awt.Component.show(Unknown Source)
java.awt.Component.setVisible(Unknown Source)
java.awt.Window.setVisible(Unknown Source)
java.awt.Dialog.setVisible(Unknown Source)
org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:518)
org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:306)
org.openstreetmap.josm.gui.MainApplication$GuiFinalizationWorker.handleAutosave(MainApplication.java:514)
org.openstreetmap.josm.gui.MainApplication$GuiFinalizationWorker.run(MainApplication.java:490)
java.awt.event.InvocationEvent.dispatch(Unknown Source)
java.awt.EventQueue.dispatchEventImpl(Unknown Source)
java.awt.EventQueue.access$500(Unknown Source)
java.awt.EventQueue$3.run(Unknown Source)
java.awt.EventQueue$3.run(Unknown Source)
java.security.AccessController.doPrivileged(Native Method)
java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
java.awt.EventQueue.dispatchEvent(Unknown Source)
java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
java.awt.EventDispatchThread.pumpEvents(Unknown Source)
java.awt.EventDispatchThread.pumpEvents(Unknown Source)
java.awt.EventDispatchThread.run(Unknown Source)

Thread: main (1)
Stacktrace see above.

Attachments (0)

Change History (14)

comment:1 Changed 10 months ago by simon04

Summary: erroArrayIndexOutOfBoundsException in KeyStore.getCertificateAlias via PlatformHookWindows.setupHttpsCertificate

comment:2 Changed 10 months ago by simon04

javabug:8139436? But it it should have been fixed for 8u102 in javabug:8148848.

comment:3 Changed 10 months ago by Don-vip

Keywords: javabug windows https certificate keystore added

comment:4 in reply to:  2 Changed 10 months ago by Don-vip

Replying to simon04:

javabug:8139436? But it it should have been fixed for 8u102 in javabug:8148848.

I have asked directly to the OpenJDK contributor who fixed this issue.

comment:5 Changed 10 months ago by Klumbumbus

Ticket #13862 has been marked as a duplicate of this ticket.

comment:6 Changed 8 months ago by Don-vip

Ticket #14154 has been marked as a duplicate of this ticket.

comment:7 Changed 8 months ago by Don-vip

Cc: erickdeoliveiraleal added

comment:8 Changed 8 months ago by Don-vip

No answer from OpenJDK contributor, new bugreport submitted: javabug:8172244

Last edited 7 months ago by Don-vip (previous) (diff)

comment:9 Changed 7 months ago by Don-vip

Ticket #14317 has been marked as a duplicate of this ticket.

comment:10 Changed 7 months ago by Don-vip

Cc: boneco added
Priority: normalmajor

comment:11 Changed 4 months ago by Don-vip

Ticket #14676 has been marked as a duplicate of this ticket.

comment:12 Changed 3 months ago by Don-vip

Ticket #14780 has been marked as a duplicate of this ticket.

comment:13 Changed 3 months ago by Don-vip

Milestone: 17.05

comment:14 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12124/josm:

fix #13855 - abort HTTPS certificate setup if JDK-8172244 occurs

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.