Modify

Opened 12 months ago

Closed 8 days ago

#13794 closed defect (duplicate)

NPE at HttpClient.connect

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report http javabug Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. bug after try to change layout

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 pl) Windows 7 64-Bit
Memory Usage: 805 MB / 910 MB (183 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768, \Display1 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Last errors/warnings:
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Błędne żądanie - <html>Serwer OSM „api.openstreetmap.org” zgłosił błędne żądanie.<br><br>Obszar, który próbowałeś pobrać lub same żądanie pobrania były zbyt duże.<br>Spróbuj pobrać mniejszy obszar albo użyj wyeksportowanego pliku udostępnionego przez społeczność OSM.</html>
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Błędne żądanie - <html>Serwer OSM „api.openstreetmap.org” zgłosił błędne żądanie.<br><br>Obszar, który próbowałeś pobrać lub same żądanie pobrania były zbyt duże.<br>Spróbuj pobrać mniejszy obszar albo użyj wyeksportowanego pliku udostępnionego przez społeczność OSM.</html>
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Błędne żądanie - <html>Serwer OSM „api.openstreetmap.org” zgłosił błędne żądanie.<br><br>Obszar, który próbowałeś pobrać lub same żądanie pobrania były zbyt duże.<br>Spróbuj pobrać mniejszy obszar albo użyj wyeksportowanego pliku udostępnionego przez społeczność OSM.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
	at java.net.HttpURLConnection.getResponseCode(Unknown Source)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)
	at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:126)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:145)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:97)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:61)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:44)
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseOsm(BoundingBoxDownloader.java:186)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.parseDataSet(DownloadOsmTask.java:312)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.realRun(DownloadOsmTask.java:320)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 8 days ago by Don-vip

Description: modified (diff)
Keywords: http added
Summary: bug after try to change layoutNPE at HttpClient.connect

comment:2 Changed 8 days ago by Don-vip

Keywords: javabug added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #13964.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.