Modify

Opened 9 months ago

Closed 2 months ago

#13770 closed defect (fixed)

Nachladen und Zoom mit Mausrad (I/O error while parsing JSON, Premature EOF)

Reported by: anonymous Owned by: floscher
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 de) Windows 10 64-Bit
Memory Usage: 789 MB / 989 MB (44 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ CADTools (1006)
+ ImproveWay (1452443304)
+ Mapillary (32882)
+ apache-commons (32699)
+ apache-http (32699)
+ continuosDownload (53)
+ jogl (1.0.46)
+ log4j (32699)
+ reverter (32796)

Last errors/warnings:
- E: java.net.SocketTimeoutException: connect timed out
- W: java.net.SocketTimeoutException: connect timed out
- W: Already here java.net.SocketTimeoutException: connect timed out
- E: java.net.SocketTimeoutException: connect timed out
- W: java.net.SocketTimeoutException: connect timed out
- W: Already here java.net.SocketTimeoutException: connect timed out
- E: java.net.SocketTimeoutException: connect timed out
- W: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte überprüfen Sie Ihre Internetverbindung.. Ursache: java.net.SocketTimeoutException: connect timed out
- W: java.lang.NoSuchMethodException: No such function prettifyValue
- W: java.lang.NoSuchMethodException: No such function prettifyValue


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-44-thread-2 (2290)
javax.json.JsonException: I/O error while parsing JSON
	at org.glassfish.json.JsonTokenizer.read(JsonTokenizer.java:444)
	at org.glassfish.json.JsonTokenizer.readNumberChar(JsonTokenizer.java:243)
	at org.glassfish.json.JsonTokenizer.readNumber(JsonTokenizer.java:272)
	at org.glassfish.json.JsonTokenizer.nextToken(JsonTokenizer.java:410)
	at org.glassfish.json.JsonParserImpl$ArrayContext.getNextEvent(JsonParserImpl.java:314)
	at org.glassfish.json.JsonParserImpl$StateIterator.next(JsonParserImpl.java:172)
	at org.glassfish.json.JsonParserImpl.next(JsonParserImpl.java:149)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:136)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:139)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:180)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:143)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:180)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:103)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySequenceDownloadThread.run(MapillarySequenceDownloadThread.java:59)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: Premature EOF
	at sun.net.www.http.ChunkedInputStream.fastRead(Unknown Source)
	at sun.net.www.http.ChunkedInputStream.read(Unknown Source)
	at java.io.FilterInputStream.read(Unknown Source)
	at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(Unknown Source)
	at sun.nio.cs.StreamDecoder.readBytes(Unknown Source)
	at sun.nio.cs.StreamDecoder.implRead(Unknown Source)
	at sun.nio.cs.StreamDecoder.read(Unknown Source)
	at java.io.InputStreamReader.read(Unknown Source)
	at java.io.BufferedReader.fill(Unknown Source)
	at java.io.BufferedReader.read1(Unknown Source)
	at java.io.BufferedReader.read(Unknown Source)
	at org.glassfish.json.JsonTokenizer.fillBuf(JsonTokenizer.java:473)
	at org.glassfish.json.JsonTokenizer.read(JsonTokenizer.java:434)
	... 16 more

Attachments (0)

Change History (2)

comment:1 Changed 9 months ago by floscher

Component: CorePlugin mapillary
Owner: changed from team to floscher
Summary: Nachladen und Zoom mit MausradNachladen und Zoom mit Mausrad (I/O error while parsing JSON, Premature EOF)

comment:2 Changed 2 months ago by floscher

Resolution: fixed
Status: newclosed

Starting with commit f71dd9b these exceptions when parsing JSON will no longer lead to a crash, but a notification is shown that the download was not successful.

This will be included in the next release after v1.5.3, which will be released soon.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain floscher.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.