Modify

Opened 13 months ago

Closed 6 months ago

Last modified 5 months ago

#13754 closed defect (wontfix)

IAE: Listener imageryadjust.ImageryAdjustMapMode was not registered before or already removed

Reported by: anonymous Ireland Owned by: team
Priority: normal Milestone:
Component: Plugin imageryadjust Version:
Keywords: template_report gsoc-core regression Cc: michael2402, bastiK, wiktorn

Description (last modified by Klumbumbus)

Attempting to correct lines caused error in which the application would not interact with the rest of the OS. Any attempts to edit the map or exit program resulted in an error notification. At first glance does not appear to be plugin conflict.

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en) Windows 7 32-Bit
Memory Usage: 453 MB / 989 MB (157 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1440x900
Maximum Screen Size: 1440x900
Dataset consistency test: No problems found

Plugins:
+ FastDraw (32938)
+ Mapillary (v1.3.1)
+ Tracer (32699)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32944)
+ fieldpapers (v0.4.0)
+ geochat (32796)
+ imageryadjust (32699)
+ log4j (32699)
+ measurement (32936)
+ print (32699)
+ reltoolbox (32796)
+ reverter (32796)
+ terracer (32699)
+ todo (30000)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)
+ walkingpapers (32796)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: Listener imageryadjust.ImageryAdjustMapMode@2f0456 (instance of imageryadjust.ImageryAdjustMapMode) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:129)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:206)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:123)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:190)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:238)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:78)
	at imageryadjust.ImageryAdjustMapMode.exitMode(ImageryAdjustMapMode.java:103)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:450)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:432)
	at org.openstreetmap.josm.actions.mapmode.MapMode.actionPerformed(MapMode.java:99)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (12)

comment:1 Changed 13 months ago by Klumbumbus

Cc: michael2402 added
Component: CoreCore imagery
Description: modified (diff)
Keywords: gsoc-core regression added
Summary: Attempting to correct lines caused error in which the application would not interact with the rest of the OS. Any attempts to edit the map or exit program resulted in an error notification. At first glance does not appear to be plugin conflict.IAE: Listener imageryadjust.ImageryAdjustMapMode@2f0456 was not registered before or already removed.

comment:2 Changed 13 months ago by Don-vip

Component: Core imageryPlugin

comment:3 Changed 9 months ago by Don-vip

Component: PluginPlugin imageryadjust

comment:4 Changed 6 months ago by Klumbumbus

Ticket #14637 has been marked as a duplicate of this ticket.

comment:5 Changed 6 months ago by Don-vip

Summary: IAE: Listener imageryadjust.ImageryAdjustMapMode@2f0456 was not registered before or already removed.IAE: Listener imageryadjust.ImageryAdjustMapMode was not registered before or already removed

comment:6 Changed 6 months ago by Don-vip

Cc: bastiK wiktorn added

@imagery experts ;)

Is the plugin "imagery adjust" still relevant? I don't see any added value versus core feature? The plugin has been created in 2009, our own ImageryAdjust class in 2010...

comment:7 Changed 6 months ago by wiktorn

Indeed, I guess we can phase this plugin out.

comment:8 Changed 6 months ago by Don-vip

In 11946/josm:

see #13754 - deprecate imageryadjust plugin

comment:9 Changed 6 months ago by Don-vip

Resolution: wontfix
Status: newclosed

comment:10 Changed 6 months ago by Klumbumbus

Ticket #14716 has been marked as a duplicate of this ticket.

comment:11 Changed 5 months ago by anonymous

Is there any documentation as to what to replace imageryadjust with? There is nothing obvious in JSOM that seems to implement the same functionality of dragging the image to suit.
Thanks.

comment:12 Changed 5 months ago by DeeHants

(Previous comment by me)
As evidence that users don't read, I hadn't noticed that the text in that dialog now says that the imagery can be dragged in the background. I'm used to dialogues being modal!

Last edited 5 months ago by DeeHants (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.