Modify

Opened 15 months ago

Closed 4 weeks ago

Last modified 2 weeks ago

#13747 closed defect (fixed)

don't select tag adding dialog fields upon focus change

Reported by: richlv Owned by: team
Priority: normal Milestone: 17.11
Component: Core Version: tested
Keywords: focus, selection Cc:

Description

josm on linux, java 1.8.0_101

select some feature, hit alt+a. start typing something in the fields.
switch to another app, switch back - as soon as josm regains focus, field contents are selected and require manual operation to resume typing.

especially annoying when trying to grab opening hours from a website and similar cases.

have been annoyed about it myself, but recently observed a novice user being hit by this, and they were quite disappointed about this behaviour.

Attachments (0)

Change History (11)

comment:1 Changed 15 months ago by Klumbumbus

I also face this problem often when I opened the upload window and type in the source field "note ", go back to browser and copy the note id. Then when I want to paste the note id the whole comment is selected.

comment:2 Changed 4 weeks ago by Don-vip

Milestone: 17.11

comment:3 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13139/josm:

fix #13747 - do not select all characters from a combobox when switching between JOSM and another application

comment:4 Changed 3 weeks ago by Klumbumbus

This doesn't work in the upload window. It always selects the whole changeset comment text, even if the cursor was in the changeset source box before.

comment:5 Changed 3 weeks ago by Don-vip

In 13144/josm:

see #13747 - fix focus/selection/size issues in upload dialog

comment:6 Changed 3 weeks ago by Klumbumbus

Works fine for me. Thanks :)

comment:7 Changed 3 weeks ago by Don-vip

Ticket #8356 has been marked as a duplicate of this ticket.

comment:8 Changed 3 weeks ago by Klumbumbus

It would be great if this behavior could also be used in text and combo boxes in the preset windows (if not too much work).

comment:9 Changed 3 weeks ago by Don-vip

In 13170/josm:

see #13747 - fix focus/selection issues in presets dialogs

comment:10 Changed 3 weeks ago by Klumbumbus

Thanks. Works fine for me.

comment:11 Changed 2 weeks ago by Don-vip

r13139 introduced a major regression, see #15627

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.