Modify

Opened 9 months ago

Closed 2 months ago

Last modified 2 months ago

#13725 closed defect (fixed)

IAE: Listener was not registered before: LayerChangeAdapter / PrintableMapView

Reported by: jensthate@… Owned by: team
Priority: major Milestone:
Component: Plugin print Version: tested
Keywords: regression gsoc-core Cc: michael2402, popov@…

Description

What steps will reproduce the problem?

  1. new installation from the scratch
  2. selecting a few plugins such us print and pdf import
  3. new start the program

What is the expected result?

  1. tweaking the program
  2. printing the work

What happens instead?

  • no map will be appear on the print apart from the preview in the left top corner
  • in sub-window for settings, or finishing the program is no content visible; only when I click on a button (blind clicking in the field) the related part of the content become visible
  • the same happen when I move the mouse over an 'blind' content and a hint pop out

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 de) Linux Ubuntu 16.04.1 LTS
Memory Usage: 853 MB / 1774 MB (190 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ BuildingGeneralization (1010)
+ ElevationProfile (32868)
+ OpenStreetView (22)
+ apache-commons (32699)
+ buildings_tools (32944)
+ globalsat (32796)
+ gpsblam (32745)
+ importvec (32699)
+ measurement (32936)
+ namemanager (32699)
+ pdfimport (32796)
+ print (32699)
+ undelete (32699)
+ utilsplugin2 (32815)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: Print request attribute not supported: spool-data-destination: class javax.print.attribute.standard.Destination - file:${HOME}/out.ps
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: java.lang.IllegalArgumentException: component not found in tabbed pane
- W: 1 problems occured during upload/save


=== REPORTED CRASH DATA ===
LayerManager#fireLayerRemoving:
 - listener: org.openstreetmap.josm.plugins.print.PrintableMapView[,0,0,956x627,invalid,alignmentX=0.0,alignmentY=0.0,border=,flags=1,maximumSize=,minimumSize=,preferredSize=]
 - event: LayerRemoveEvent [removedLayer=WMSLayer [info=ImageryInfo{name='PNOA Spain', countryCode='ES', url='http://www.idee.es/wms/PNOA/PNOA?REQUEST=GetMap&VERSION=1.1.1&SERVICE=WMS&SRS={proj}&LAYERS=pnoa&STYLES=default&FORMAT=image/jpeg&WIDTH={width}&HEIGHT={height}&BBOX={bbox}', imageryType=WMS}], lastLayer=false]
 - layer: WMSLayer [info=ImageryInfo{name='PNOA Spain', countryCode='ES', url='http://www.idee.es/wms/PNOA/PNOA?REQUEST=GetMap&VERSION=1.1.1&SERVICE=WMS&SRS={proj}&LAYERS=pnoa&STYLES=default&FORMAT=image/jpeg&WIDTH={width}&HEIGHT={height}&BBOX={bbox}', imageryType=WMS}]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [org.openstreetmap.josm.actions.ImageryAdjustAction@61f53fec]
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:364)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:352)
	at org.openstreetmap.josm.actions.JosmAction.destroy(JosmAction.java:220)
	at org.openstreetmap.josm.actions.ImageryAdjustAction.destroy(ImageryAdjustAction.java:328)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.destroy(AbstractTileSourceLayer.java:1993)
	at org.openstreetmap.josm.gui.MapView.layerRemoving(MapView.java:760)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerRemoving(LayerManager.java:396)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveSingleLayer(LayerManager.java:225)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:282)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:219)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:205)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:205)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:423)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.resetState(MainLayerManager.java:392)
	at org.openstreetmap.josm.Main.shutdown(Main.java:996)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:116)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:977)
	at org.openstreetmap.josm.gui.MainFrame$1.windowClosing(MainFrame.java:94)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.Window.processWindowEvent(Window.java:2054)
	at javax.swing.JFrame.processWindowEvent(JFrame.java:305)
	at java.awt.Window.processEvent(Window.java:2013)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (17)

comment:1 Changed 9 months ago by Klumbumbus

Component: unspecifiedCore imagery
Keywords: regression added
Milestone: 16.09

Still a bug of the imagery adjustment?

comment:2 Changed 9 months ago by Don-vip

Cc: michael2402 added
Keywords: gsoc-core added

comment:3 Changed 9 months ago by simon04

Milestone: 16.0916.10

Milestone renamed

comment:4 Changed 9 months ago by simon04

Summary: bug during ending the programImageryAdjustAction: Listener was not registered before: LayerChangeAdapter

comment:5 Changed 8 months ago by simon04

Milestone: 16.1016.11

comment:6 Changed 7 months ago by Don-vip

Milestone: 16.1116.12

Milestone renamed

comment:7 Changed 6 months ago by Don-vip

Milestone: 16.1217.01

comment:8 Changed 5 months ago by Don-vip

Component: Core imageryPlugin print
Keywords: printing settings removed
Milestone: 17.01

Comes from plugin print in fact.

comment:9 Changed 5 months ago by Don-vip

Ticket #14262 has been marked as a duplicate of this ticket.

comment:10 Changed 5 months ago by Don-vip

Cc: popov@… added

comment:11 Changed 5 months ago by Don-vip

Summary: ImageryAdjustAction: Listener was not registered before: LayerChangeAdapterPrint: Listener was not registered before: LayerChangeAdapter / PrintableMapView

comment:12 Changed 5 months ago by stoecker

Ticket #14293 has been marked as a duplicate of this ticket.

comment:13 Changed 3 months ago by stoecker

Ticket #14565 has been marked as a duplicate of this ticket.

comment:14 Changed 2 months ago by Don-vip

Priority: normalmajor

comment:15 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33260:33261].

comment:16 Changed 2 months ago by Don-vip

Summary: Print: Listener was not registered before: LayerChangeAdapter / PrintableMapViewListener was not registered before: LayerChangeAdapter / PrintableMapView

comment:17 Changed 2 months ago by Don-vip

Summary: Listener was not registered before: LayerChangeAdapter / PrintableMapViewIAE: Listener was not registered before: LayerChangeAdapter / PrintableMapView

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.