Modify

Opened 11 months ago

Closed 4 months ago

#13693 closed defect (fixed)

Listener cadastre_fr.WMSAdjustAction was not registered before or already removed.

Reported by: anonymous Owned by: pieren
Priority: major Milestone:
Component: Plugin cadastre-fr Version:
Keywords: template_report regression gsoc-core Cc: michael2402, pierrecparmentier@…

Description

What steps will reproduce the problem?

  1. create layer
  2. use IGN orthophoto map

What is the expected result?

The application close when I quit

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

just text aerial picture

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 fr) Mac OS X 10.9.5
Memory Usage: 419 MB / 910 MB (57 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69732482 1440x900, Display 188790067 1400x1050
Maximum Screen Size: 1440x1050
VM arguments: [-Djava.library.path=/Applications/josm-macosx/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]

Plugins:
+ DirectDownload (32699)
+ DirectUpload (32699)
+ DxfImport (1008)
+ ImageWayPoint (32699)
+ ImportImagePlugin (32699)
+ Mapillary (v1.3.0)
+ PicLayer (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ cadastre-fr (32950)
+ ejml (32680)
+ fieldpapers (v0.4.0)
+ geotools (32813)
+ jts (32699)
+ log4j (32699)
+ measurement (32936)
+ pdfimport (32796)
+ photo_geotagging (32699)
+ photoadjust (32863)

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryChangesetDialog$SubmitAction@196e81aa
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryChangesetDialog$SubmitAction@56099859
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: java.lang.reflect.InvocationTargetException. Cause : java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause : java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause : java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause : java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause : java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.IllegalArgumentException: Listener cadastre_fr.WMSAdjustAction@23d00b4a (instance of cadastre_fr.WMSAdjustAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:129)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:206)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:123)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:190)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:238)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:78)
	at cadastre_fr.WMSAdjustAction.exitMode(WMSAdjustAction.java:61)
	at org.openstreetmap.josm.gui.MapFrame.activeOrEditLayerChanged(MapFrame.java:777)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.fireActiveLayerChange(MainLayerManager.java:254)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.setActiveLayer(MainLayerManager.java:247)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:279)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:219)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:205)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:205)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:423)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.resetState(MainLayerManager.java:392)
	at org.openstreetmap.josm.Main.shutdown(Main.java:996)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:116)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:977)
	at org.openstreetmap.josm.tools.PlatformHookOsx.invoke(PlatformHookOsx.java:147)
	at com.sun.proxy.$Proxy0.handleQuitRequestWith(Unknown Source)
	at com.apple.eawt._AppEventHandler$_QuitDispatcher.performUsing(_AppEventHandler.java:395)
	at com.apple.eawt._AppEventHandler$_QuitDispatcher.performUsing(_AppEventHandler.java:388)
	at com.apple.eawt._AppEventHandler$_AppEventDispatcher$1.run(_AppEventHandler.java:516)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (10)

comment:1 Changed 11 months ago by Don-vip

Cc: michael2402 added
Component: CorePlugin cadastre-fr
Keywords: regression gsoc-core added
Owner: changed from team to pieren
Priority: minornormal

comment:2 Changed 10 months ago by Klumbumbus

possible duplicate #13863

comment:3 Changed 10 months ago by Klumbumbus

Summary: close applicationListener cadastre_fr.WMSAdjustAction was not registered before or already removed.

comment:4 Changed 9 months ago by Klumbumbus

Ticket #13943 has been marked as a duplicate of this ticket.

comment:5 Changed 8 months ago by Klumbumbus

Ticket #14147 has been marked as a duplicate of this ticket.

comment:6 Changed 5 months ago by Klumbumbus

Ticket #14546 has been marked as a duplicate of this ticket.

comment:7 Changed 5 months ago by Klumbumbus

Ticket #14580 has been marked as a duplicate of this ticket.

comment:8 Changed 5 months ago by Klumbumbus

Cc: pierrecparmentier@… added

comment:9 Changed 5 months ago by Don-vip

Priority: normalmajor

comment:10 Changed 4 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33226:33227].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pieren.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.