Modify

Opened 13 months ago

Last modified 3 months ago

#13604 reopened defect

IAE: Cannot paint layer, it is not registered (OsmDataLayer)

Reported by: dieterdreist Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: template_report layer regression gsoc-core Cc: michael2402, baditaflorin, skyper, hs-rook, anderfo, dh0dz@…

Description

What steps will reproduce the problem?

  1. startup
  2. download an area (normal, not big)
  3. when finished / preparing data/display it throws and exception

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-09 02:34:36 +0200 (Fri, 09 Sep 2016)
Build-Date:2016-09-09 01:35:10
Revision:10982
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10982 en) Mac OS X 10.11.6
Memory Usage: 847 MB / 1820 MB (736 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188875522 1920x1080, Display 458628992 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dsun.java2d.opengl=true]

Plugins:
+ alignways (32921)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32944)
+ ejml (32680)
+ geochat (32796)
+ geotools (32813)
+ imagery_offset_db (32796)
+ jts (32699)
+ measurement (32936)
+ opendata (32898)
+ print (32699)
+ reltoolbox (32796)
+ reverter (32796)
+ undelete (32699)
+ utilsplugin2 (32815)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: Invalid jar file ''<josm.userdata>/plugins/measurement.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/opendata.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/buildings_tools.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/alignways.jar.new'' (exists: false, canRead: false)
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin TombPlugin. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoSuchMethodError: kendzi.josm.plugin.tomb.action.TombAction.getCurrentDataSet()Lorg/openstreetmap/josm/data/osm/DataSet;
- W: Disable plugin - Could not load plugin TombPlugin. Delete from preferences?


=== REPORTED CRASH DATA ===
MapView#paintLayer:
 - layer: OsmDataLayer [name=Data Layer 1, associatedFile=null]
 - bounds: Bounds[41.8218078,12.4418674,41.8854403,12.5087919]

Warning issued by: MapView#paintLayer

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:427)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:504)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1047)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1579)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1502)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1673)
	at java.awt.Component.setVisible(Component.java:1625)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor.lambda$doBeginTask$2(PleaseWaitProgressMonitor.java:186)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (36)

comment:1 Changed 13 months ago by dieterdreist

Cc: dieterdreist added

comment:2 Changed 13 months ago by Don-vip

Cc: michael2402 added; dieterdreist removed
Keywords: layer regression gsoc-core added
Reporter: changed from anonymous to dieterdreist
Summary: exception on startupIllegalArgumentException: Cannot paint layer, it is not registered

comment:3 Changed 13 months ago by Don-vip

Do you know how did you create "Data Layer 1" ? With JOSM core functions or with a plugin?

comment:4 Changed 13 months ago by anonymous

I really did almost nothing, just started josm, downloaded a small area (like 200x200m) and the exception occurred directly after download, before I touched anything.

comment:5 Changed 13 months ago by michael2402

Component: CoreCore mappaint

comment:6 Changed 12 months ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13503.

comment:7 Changed 12 months ago by simon04

Resolution: duplicate
Status: closedreopened
Summary: IllegalArgumentException: Cannot paint layer, it is not registeredIllegalArgumentException: Cannot paint layer, it is not registered (OsmDataLayer)

comment:8 Changed 12 months ago by simon04

Ticket #13619 has been marked as a duplicate of this ticket.

comment:9 Changed 12 months ago by simon04

Ticket #13629 has been marked as a duplicate of this ticket.

comment:10 Changed 12 months ago by simon04

Cc: baditaflorin skyper added

comment:11 Changed 12 months ago by simon04


Last edited 12 months ago by simon04 (previous) (diff)

comment:12 Changed 12 months ago by simon04

Milestone: 16.10
Priority: normalmajor

comment:13 Changed 12 months ago by simon04

Milestone: 16.1016.11

comment:14 Changed 10 months ago by Don-vip

Milestone: 16.1116.12

Milestone renamed

comment:15 Changed 10 months ago by skyper

Ticket #14121 has been marked as a duplicate of this ticket.

comment:16 Changed 10 months ago by skyper

Ticket #14122 has been marked as a duplicate of this ticket.

comment:17 Changed 10 months ago by skyper

Cc: hs-rook added

comment:18 Changed 10 months ago by skyper

Ticket #13976 has been marked as a duplicate of this ticket.

comment:19 Changed 10 months ago by skyper

Cc: anderfo added

comment:20 Changed 10 months ago by skyper

Ticket #14039 has been marked as a duplicate of this ticket.

comment:21 Changed 10 months ago by Don-vip

Milestone: 16.1217.01

Michael can you please look into this one? The problem seems to occur quite often.

comment:22 Changed 9 months ago by Don-vip

Milestone: 17.0117.02

comment:23 Changed 8 months ago by Don-vip

Ticket #14348 has been marked as a duplicate of this ticket.

comment:24 Changed 8 months ago by Klumbumbus

Ticket #14355 has been marked as a duplicate of this ticket.

comment:25 Changed 8 months ago by Klumbumbus

Cc: dh0dz@… added

comment:26 Changed 8 months ago by Don-vip

Milestone: 17.0217.03

comment:27 Changed 7 months ago by michael2402

In 11765/josm:

See #13604: Add more debug info to trace this.

comment:28 Changed 7 months ago by Don-vip

Milestone: 17.0317.04

comment:29 Changed 6 months ago by Don-vip

Summary: IllegalArgumentException: Cannot paint layer, it is not registered (OsmDataLayer)IAE: Cannot paint layer, it is not registered (OsmDataLayer)

comment:30 Changed 6 months ago by Don-vip

Ticket #13627 has been marked as a duplicate of this ticket.

comment:31 Changed 6 months ago by Don-vip

Ticket #14223 has been marked as a duplicate of this ticket.

comment:32 Changed 6 months ago by michael2402

In 12030/josm:

See #13604: Change error to a warning until we figure out what causes a layer not to be registered at that stage.

comment:33 Changed 6 months ago by michael2402

Milestone: 17.0417.05

comment:34 Changed 5 months ago by Don-vip

Milestone: 17.0517.06

comment:35 Changed 4 months ago by Don-vip

Milestone: 17.0617.07

comment:36 Changed 3 months ago by Don-vip

Milestone: 17.07
Priority: majornormal

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to dieterdreist
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.