Modify

Opened 14 months ago

Closed 8 months ago

Last modified 8 months ago

#13470 closed defect (fixed)

IllegalArgumentException when activating Yahoo imagery

Reported by: joed5 Owned by: joed5
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: template_report yahoo Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Opern Josm and download data from Bengaluru/India, south
  2. Click background picture "yahoo"

What is the expected result?

a background picture from yahoo is overlayed

What happens instead?

error message (see below)

Please provide any additional information below. Attach a screenshot if possible.

screenshot

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 de) Windows 10 64-Bit
Memory Usage: 224 MB / 455 MB (94 MB allocated, but free)
Java version: 1.8.0_66-b18, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
+ ColumbusCSV (32796)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ buildings_tools (32796)
+ osmarender (32699)
+ print (32699)
+ terracer (32699)

Last errors/warnings:
- W: Erweiterungen aktualisieren - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: Invalid jar file ''<josm.pref>\plugins\terracer.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\PicLayer.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\ColumbusCSV.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\buildings_tools.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\print.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\OpeningHoursEditor.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\osmarender.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\RoadSigns.jar.new'' (exists: false, canRead: false)
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: Fehler beim Erstellen der Kachelquelle. Ursache: java.lang.IllegalArgumentException: Fehler beim Erstellen der Kachelquelle

OSM API: http://www.openstreetmap.org/api


=== REPORTED CRASH DATA ===
MapView#layerAdded:
 - layer: org.openstreetmap.josm.gui.layer.WMSLayer@715dc427

LayerManager#fireLayerAdded:
 - listener: org.openstreetmap.josm.gui.MapView[,0,78,1158x888,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=java.awt.Dimension[width=10,height=0],preferredSize=]
 - event: LayerAddEvent [addedLayer=org.openstreetmap.josm.gui.layer.WMSLayer@715dc427]

BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: Fehler beim Erstellen der Kachelquelle
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.initializeIfRequired(AbstractTileSourceLayer.java:705)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.attachToMapView(AbstractTileSourceLayer.java:684)
	at org.openstreetmap.josm.gui.MapView.layerAdded(MapView.java:631)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerAdded(LayerManager.java:379)
	at org.openstreetmap.josm.gui.layer.LayerManager.realAddLayer(LayerManager.java:191)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realAddLayer(MainLayerManager.java:267)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$addLayer$0(LayerManager.java:180)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:180)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:72)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

Zwischenablage01.jpg (508.1 KB) - added by anonymous 14 months ago.
screenshot

Download all attachments as: .zip

Change History (17)

Changed 14 months ago by anonymous

Attachment: Zwischenablage01.jpg added

screenshot

comment:1 Changed 14 months ago by anonymous

regards from Stuttgart

comment:2 Changed 14 months ago by Klumbumbus

Independent from the error message, Yahoo imagery is no longer free to use for osm since 2011, see http://wiki.openstreetmap.org/wiki/Yahoo!_Aerial_Imagery. Did you create this wms entry yourself or is this an old entry from the list from within JOSM?

Last edited 14 months ago by Klumbumbus (previous) (diff)

comment:3 Changed 14 months ago by Don-vip

Description: modified (diff)

comment:4 Changed 14 months ago by stoecker

Ticket #13493 has been marked as a duplicate of this ticket.

comment:5 Changed 14 months ago by Don-vip

Component: CoreCore imagery
Keywords: yahoo added

comment:6 Changed 14 months ago by Don-vip

Owner: changed from team to joed5
Status: newneedinfo

comment:7 Changed 14 months ago by Don-vip

Summary: Hintergrundbild "Yahoo" einblenden bringt FehlermeldungIllegalArgumentException when activating Yahoo imagery

comment:8 Changed 14 months ago by Don-vip

Ticket #13531 has been marked as a duplicate of this ticket.

comment:9 Changed 14 months ago by Klumbumbus

I think there should be a mechanism in JOSM which automatically removes imagery entries, which were once added from the internal list but which are no longer in the list. It is not OK that 5 years after we lost the permission to use yahoo imagery it is still available in the JOSMs of some users. (given that this entry was not added manually by the user)

comment:10 Changed 14 months ago by Don-vip

Another question is why do we get suddenly many reports if Yahoo has been removed 5 years ago?

comment:11 Changed 14 months ago by Klumbumbus

OK, from our list it was removed only 20 months ago https://josm.openstreetmap.de/wiki/Maps?sfp_email=&sfph_mail=&action=diff&version=347&old_version=346&sfp_email=&sfph_mail= , but this is still a long time.

comment:12 in reply to:  10 Changed 14 months ago by stoecker

Replying to Don-vip:

Another question is why do we get suddenly many reports if Yahoo has been removed 5 years ago?

Rework did break "html:" method?

comment:13 Changed 8 months ago by stoecker

Resolution: fixed
Status: needinfoclosed

In 11578/josm:

fix #13470 - drop last remaining HTML imagery part

comment:14 Changed 8 months ago by stoecker

In 11579/josm:

see #13470 - drop last remaining HTML imagery part in maps.xsd

comment:15 Changed 8 months ago by stoecker

In 11580/josm:

see #13470 - drop last remaining HTML imagery part in windows installer (uninstaller still contains something)

comment:16 Changed 8 months ago by stoecker

In 11581/josm:

see #13470 - hopefully finally drop last remaining HTML imagery part

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain joed5.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.