Modify

Opened 10 months ago

Closed 8 days ago

#13044 closed defect (duplicate)

IAE: Listener was not registered before: LayerChangeAdapter (ToggleDialogAction)

Reported by: michael2402 Owned by: team
Priority: normal Milestone:
Component: Plugin shapetools Version:
Keywords: template_report gsoc-core regression Cc:

Description

The shape tools plugin registers a layer listener and removes it in destroy(). This listener is never added again.

What steps will reproduce the problem?

  1. Create new layer
  2. Remove it
  3. Create new layer
  4. Remove it

Please provide any additional information below. Attach a screenshot if possible.

Build-Date:2016-06-24 06:58:59
Revision:10473
Is-Local-Build:true

Identification: JOSM/1.5 (10473 SVN de) Linux Ubuntu 14.04.3 LTS
Memory Usage: 697 MB / 3559 MB (493 MB allocated, but free)
Java version: 1.7.0_79-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u79-2.5.6-0ubuntu1.14.04.1
VM arguments: [-Djosm.home=<josm.pref>/]
Program arguments: [--set=expert=true, --set=remotecontrol.enabled=true, --set=debug.edt-checker.enable=false]

Plugins:
- FastDraw (32158)
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- ImportImagePlugin (32287)
- InfoMode (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- ShapeTools (1000)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- continuosDownload (53)
- contourmerge (1014)
- download_along (32158)
- ejml (32158)
- ext_tools (32158)
- geotools (31895)
- gson (32158)
- imagery_offset_db (32158)
- jts (31906)
- log4j (32158)
- mapdust (31923)
- measurement (32324)
- opendata (32289)
- photo_geotagging (32158)
- photoadjust (32158)
- reltoolbox (32158)
- reverter (32158)
- tag2link (31923)
- tageditor (32158)
- terracer (32158)
- todo (29154)
- turnrestrictions (32375)
- undelete (32158)
- utilsplugin2 (32158)
- waydownloader (32158)
- wikipedia (32182)

Last errors/warnings:
- W: Old style SideButton usage for action org.wikipedia.WikipediaToggleDialog$WikipediaLoadCategoryAction@5caf331
- W: Old style SideButton usage for action org.wikipedia.WikipediaToggleDialog$PasteWikipediaArticlesAction@d496e8
- W: Old style SideButton usage for action org.wikipedia.WikipediaToggleDialog$AddWikipediaTagAction@6a106ce4
- W: Old style SideButton usage for action org.wikipedia.WikipediaToggleDialog$WikipediaSettingsAction@183601a5
- E: java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [ToggleDialogAction [Shape actions panel]]

java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [ToggleDialogAction [Shape actions panel]]
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:345)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:333)
	at org.openstreetmap.josm.actions.JosmAction.destroy(JosmAction.java:220)
	at org.openstreetmap.josm.gui.IconToggleButton.destroy(IconToggleButton.java:72)
	at org.openstreetmap.josm.gui.MapFrame.destroy(MapFrame.java:346)
	at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:61)
	at org.openstreetmap.josm.gui.MainPanel$1$1.run(MainPanel.java:170)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:745)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:715)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (4)

comment:1 Changed 10 months ago by Don-vip

Keywords: gsoc-core added

comment:2 Changed 5 weeks ago by Klumbumbus

Keywords: regression added

comment:3 Changed 8 days ago by Don-vip

Summary: ShapeTools: Layer listener removed twiceIAE: Listener was not registered before: LayerChangeAdapter (ToggleDialogAction)

comment:4 Changed 8 days ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13529.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.