Changes between Initial Version and Version 1 of Ticket #13036, comment 22


Ignore:
Timestamp:
2017-09-03T10:00:31+02:00 (3 weeks ago)
Author:
michael2402
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #13036, comment 22

    initial v1  
    2424It might be a plus for users as well if we don't change things in hidden layers on undo but only in the active, visible layer.
    2525
     26While we are on it: Make that undo/redo queue implement an interface (e.g. `UndoRedo`). then add a `UndoRedo getUndoRedo()` to the `Layer` class.  It will make the code much more universal and we can add undo/redo to other layers later without changing the UI code.
     27
    2628(4)
    2729Dataset names are a nice-to-have feature. So even if we change to DS command queues, we can keep them to make debugging easier.