Modify

Opened 15 months ago

Closed 4 months ago

#12861 closed defect (fixed)

NullPointerException in MapillaryTrafficSignDownloadThread

Reported by: Polyglot Owned by: Polyglot
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Go to an area with many pictures. JOSM slows down a lot.
  2. Go to another area 2000km away. JOSM reports a crash

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-18 23:27:06 +0200 (Wed, 18 May 2016)
Build-Date:2016-05-19 01:32:41
Revision:10253
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10253 en) Windows 7 64-Bit
Memory Usage: 508 MB / 2889 MB (164 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- CustomizePublicTransportStop (0.2)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- RoadSigns (32177)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- geochat (32158)
- livegps (32158)
- measurement (32158)
- reverter (32158)
- scripting (30722)
- surveyor (32158)
- tag2link (31923)
- terracer (32158)
- todo (29154)
- tofix (203)
- turnrestrictions (32158)
- undelete (32158)
- utilsplugin2 (32158)
- wikipedia (32182)

Last errors/warnings:
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- E: java.lang.NullPointerException
- W: java.net.SocketTimeoutException: Read timed out
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at org.glassfish.json.JsonObjectBuilderImpl$JsonObjectImpl.getString(JsonObjectBuilderImpl.java:199)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryTrafficSignDownloadThread.run(MapillaryTrafficSignDownloadThread.java:71)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 15 months ago by nokutu

Owner: changed from nokutu to Polyglot
Status: newneedinfo

Hey Polyglot, in which country were you when this happened? Mapillary recently added traffic signs in more countries and, as they are not in the plugin yet, they may cause exception.

comment:2 Changed 13 months ago by anonymous

Ticket #12884 has been marked as a duplicate of this ticket.

comment:3 Changed 12 months ago by Don-vip

Summary: Mapillary plugin crashes JOSMNullPointerException in MapillaryTrafficSignDownloadThread

comment:4 Changed 7 months ago by Don-vip

Ticket #13459 has been marked as a duplicate of this ticket.

comment:5 Changed 4 months ago by floscher

Resolution: fixed
Status: needinfoclosed

The downloading of traffic signs has been completely revised for v1.5.0 and all newer releases.

For this change the class MapillaryTrafficSignDownloadThread has been replaced with DetectionDownloadRunnable and JsonDetectionDecoder. So this exception should no longer occur with newer versions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Polyglot.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.