Modify

#12782 closed defect (duplicate)

Small-scale font size not changable

Reported by: jengelh@… Owned by: jengelh@…
Priority: normal Milestone:
Component: Internal mappaint style Version:
Keywords: Cc:

Description

The "mappaint.fontsize" property is only used for zoom levels up to "124" (s1.png). Starting level "131" (s2.png), JOSM 9979 uses some unchangable tiny font size.

Attachments (5)

s1.png (475.3 KB) - added by jengelh@… 20 months ago.
s2.png (388.2 KB) - added by jengelh@… 20 months ago.
d1.png (287.3 KB) - added by jengelh@… 20 months ago.
default style, note the 18pt fonts
d2.png (309.7 KB) - added by jengelh@… 20 months ago.
default style, one level zoomed in; font size reduces automatically
y1.png (362.4 KB) - added by jengelh@… 19 months ago.
happy output with hidpi (for completeness)

Download all attachments as: .zip

Change History (13)

Changed 20 months ago by jengelh@…

Attachment: s1.png added

Changed 20 months ago by jengelh@…

Attachment: s2.png added

comment:1 Changed 20 months ago by Klumbumbus

Component: CoreInternal mappaint style
Owner: changed from team to jengelh@…
Status: newneedinfo
  • Which mappaint style do you use?
  • To which numbers do you refer with "124" and "131"?
  • Please also add your status report (see newticket)

comment:2 Changed 20 months ago by jengelh@…

I am using Potlatch2 style. However, the issue also shows on the Default JOSM Mapcss style.

The numbers 124 and 131 refer to the numbers displayed above the zoom scale bar in the upper left hand corner of the map drawing area.

Changed 20 months ago by jengelh@…

Attachment: d1.png added

default style, note the 18pt fonts

Changed 20 months ago by jengelh@…

Attachment: d2.png added

default style, one level zoomed in; font size reduces automatically

comment:3 in reply to:  2 Changed 19 months ago by Don-vip

Replying to jengelh@…:

I am using Potlatch2 style.

Please provide your status report as per newticket + Klumbumbus' request.

comment:4 Changed 19 months ago by Klumbumbus

In 10177/josm:

see #12782 - adjust zoom dependend font size: fix z18 when mappaint.fontsize is modified by the user; change font size at z20- from 10 to 11 because 9 and 10 are nearly the same in default noto font

comment:5 Changed 19 months ago by Klumbumbus

  • regarding general font size: this ticket is a duplicate of #9995.
  • regarding the default style: because the font sizes are zoom dependend it overrides the advanced preference mappaint.fontsize. As temporary solution use Styles/HiDPISupport until #9995 is fixed
  • regarding Potlatch style: It is nearly unmaintained. Probably the same problem like with the default style but without a solution at the moment.
Last edited 19 months ago by Klumbumbus (previous) (diff)

comment:6 Changed 19 months ago by Klumbumbus

BTW: your potlatch screenshot s2 is pretty good readable to me on my screen (22" 1680*1050). What is your monitor size?

Last edited 19 months ago by Klumbumbus (previous) (diff)

comment:7 Changed 19 months ago by jengelh@…

1920×1080 pixels on 278×156mm (amounts to 175 dpi). I prefer to have my letters be shown in sizes of at least 4 mm in height. Using the hidpi style and the font-size-summand variable works well enough that I am absolutely content.

Changed 19 months ago by jengelh@…

Attachment: y1.png added

happy output with hidpi (for completeness)

comment:8 Changed 19 months ago by Klumbumbus

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #9995.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jengelh@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.